UVerse & WD can't autonegotiate? Seriously?

Those devices for which I did not set a static IP always grab the same network IP from the Arris, but I manually set the IP for 5 devices to ensure the same IP is always pulled.

The IP I’m referring to for the laptop is a different animal – it’s the IP address which is seen from outside of the network for services such as Google Analytics (so my traffic can be blocked from analytics stats, for example).

I don’t need to access the laptop using an IP, so I don’t honestly care what it is, but I need to access network devices from the laptop, so the network cares what it is. All of my other devices recognize that, despite having what AT&T/Arris refer to as a “public IP” assigned that the laptop is on the same “private network” and those other devices permit me to access them. This WD device is the only one which doesn’t.

In my case I do have the My Cloud connected to the Arris NVG589 and have NO problems what so ever with the network connection to the My Cloud. But then again I have a single public IP address that is assigned to the router itself not one of devices behind the router.

Snipped a bunch of the info. All that extra information now explains one or two things and now makes sense why you are having trouble accessing the My Cloud Dashboard under certain instances. By default if your using a computer that has an IP Address on a completely different IP Address range then that used by the My Cloud then the Dashboard will typically reject that computer’s attempt to access the dashboard.

Any particular reason (if above I missed it) why you are using public IP addresses on your computers and not the private (ex. 192.x.x.x or 10.x.x.x or 172.x.x.x) IPv4 pool of IP addresses that is typically standard for local private networks?

OK, perhaps not all are WDStaff, but none are users (like you and I are, etc.). My guess is that most of the moderators are contract workers. So let’s ask them, but then maybe these two lists can help determine who is who:

The list of Moderators:

The list of Staff:

“Single public IP address” is the key. AT&T doesn’t do that under U-verse. They rent you a block of 8 for $15/month and 5 are usable. Then you have to assign these “public IPs” to individual devices. (They also don’t disclose this until the tech has already ripped out your DSL and installed U-verse.) The router is assigned a dynamic IP which can change whenever AT&T feels like it wants to change it and the router’s IP isn’t even close to the range of your “assiged block.”

I need to pull Google Analytics stats for several websites and exclude my visits in the stats. The easiest way to do this is to block my IP from Analytics. The easiest way to block IP is to assign my laptop a permanent public IP. (That’s my reason for assigning a public IP to my laptop.)

All that said and now realized: With my public IP set on my laptop, every other device on this network let’s me in except the WD MyCloud. Also, immediately after putting the Ethernet switch in, I was able to access the Dashboard without changing my laptop’s IP. Upon booting the Arris, the Dashboard started throwing errors (and all other devices are STILL accessible.)

It’s like the MyCloud doesn’t see we’re all on “Home Network,” but everything else does, regardless of IP for any/everything.

Right. That’s how it’ supposed to work. Except that the other devices see the laptop as being on the same network AND the MyCloud was viewable one time.

How many devices are on the local network? More than five?

How is the Arris router’s LAN > DHCP configured? Is it configured manually? Or configured to use the 192.x or 172.x range?

What is the New Device DHCP Pool set too? Private or Public?

They apparently did in my market before AT&T sold off my state to Frontier. AT&T transitioned me from DSL which I had for many years to Uverse and I didn’t get a block of static IP addresses post conversion (or they didn’t tell me about it, nor program the router/gateway for it).

Edit to add: One additional comment. Even when AT&T assigns a block of IP addresses to a customer the customer doesn’t have to use them. One should be able to configure the AT&T router to use its internal DHCP server to hand out IP Addresses in the 192.x or 172.x range rather than use the public static IP address block.

Right. But they cost $15/month, so to have them and not use them seems silly. I noted the purpose above. It’s either use the static public IP or twiddle with Analytics stats for multiple sites I manage.

I too had DSL and a static IP and was very clear as to what my needs were when they “upgraded” me. The lack of disclosure, failed support, connectivity problems, and billing errors sent me to the FTC. I am not a fan of AT&T.

There’s more to a Router, Gateway, MyCloud that just the WD & AT&T logo. Think about all the low level chipset code from the different vendors that must work together 1000% of the time. Just saying…

Posting in an effort to mark this issue resolved, however disatisfying that resolution may be.

For those searching these forums for a resolution to your MyCloud device not auto-negotiating with your AT&T Arris NVG589 router, if you don’t mind spending more money, despite that WD never gave you the idea you’d require additional equipment because your MyCloud would work “out of the box,” I can confirm that adding an Ethernet switch between the Arris NVG589 router and MyCloud can solve the problem of your MyCloud not being accessible from within your AT&T network. We happened to have the TP-Link SG1005D switch available for another project and it works. Available here at Amazon for $20. Our local Office Depot also carried it; same price.

If you’re smart enough to be searching these forums prior to making your WD MyCloud purchase, either choose another cloud product or purchase an Ethernet switch at the same time to save yourself some headaches. “Out of the box” it’s just another pretty paperweight; “some assembly required.”

And because I strayed from my initial post topic part way through this conversation, if you were able to see the MyCloud Dashboard once and then never again AND you’re using a public static IP from the paid-for AT&T block/pool, you can access the dashboard by either (1) using a device which is NOT using one from the paid-for block or (2) changing the device from which you’re attempting to access the Dashboard to use either a static or dynamic IP from the private pool, restarting your router, then trying again. Details in another post above.

Still no clue as to why the dashboard was visible once while my laptop was assigned the static public IP from my block or why I can see every other device (despite that it’s not supposed to work this way), but hoping this prevents someone commencing hair pulling.

[quote=“WD_Frustrated, post:30, topic:178538, full:true”]
For those searching these forums for a resolution to your MyCloud device not auto-negotiating with your AT&T Arris NVG589 router,…[/quote]
There must be something specific with the AT&T firmware on your NVG589 if your entire issue isn’t solely related to the use if the five assigned static IP addresses from AT&T. On the NVG589, running version 9.1.0h13d5, that I use through Frontier (which still has the AT&T branding on the front by the way) works fine with the My Cloud directly connected to it. No “auto negotiation” issues. No extra configuration was needed for the My Cloud, just plug and play.

That my well be, but, when using a public static IP from my AT&T pool AND being connected to my home network, I can access my cloud cam at, say, 198.168.1.xx:20xx (pre- and post-router reboots), but no way I can access the WD MyCloud at 198.168.1.xx or at same IP with open/assigned port attribute in the link.

I’m not gonna say anything nice about AT&T probably ever again in my life, since this mess that is U-verse was installed here. But I have two printers (one Ethernet, one wireless), 4 cams (previously Ethernet - for setup - then switched to wireless), a Canon camera (wireless), laptop (switches between wireless and Ethernet), and a Verizon mini-tower (Ethernet) which all work fine and are accessible as advertised. This WD MyCloud is the only thing I couldn’t access when connected directly via Ethernet and which required a switch.

Folks, I’m wishing I’d have noticed this thread when it first popped up.

The advise about forcing a specific speed & duplex can be really messy. This “may” work with Gigabit ethernet, but will usually not work correctly for 100 meg. Doing that disables auto-negotiation entirely for that system. When one end has it disabled and the other enabled, the “enabled” end MUST always choose HALF duplex. When one end is full and the other is half, bad things happen.

Now with Gig, Half-duplex technically is not allowed – The IEEE802.3ab standard only allows full duplex with Gigabit Ethernet.

Secondly, I’ve been building enterprise networking for close to 25 years now as a profession – since before even 10BaseT was a standard and ethernet networks were built using thick coaxial cables, and Cisco had fewer than a thousand employees. I can tell you with certainty that, though VERY rare, there’s still instances where Brand X and Brand Y do not properly auto-negotiate links correctly or reliably.

In my enterprise network, there are almost 250,000 ports installed and the number of combinations is staggering. There’s hundreds of systems on this network that don’t auto-negotiate correctly, and we have to massage them onto the network.

Blaming one vendor for the error is disingenuous without thorough laboratory testing to determine the cause.