UVerse & WD can't autonegotiate? Seriously?

After spending two hours messing around with everything I was pretty sure wasn’t broken, I find this thread indicating that I can’t use my brand spanking new $162 brick without buying another $20 part because AT&T and WD can’t get their software to talk to each other? Am I reading this right?

It’s not like we’re using ABC123 Back Woods Telephone Co., WD. AT&T is one of the world’s largest telecommunications companies, as you are the same in drives.

To say I’m disappointed isn’t enough. I’m irritated and frustrated and sending your drive back to you. This is ridiculous.

I assume that means you’ll blame AT&T equally for providing hardware to their customers that cannot communicate property with their customer’s equipment and will be returning AT&T’s equpment back to them… right?

If you notice so far there are few if any others who are having the problems AT&T Uverse customers are having which necessitate the need for a switch/hub between the broadband provider’s equipment and the WD My Cloud. That is what we call a clue that perhaps its not the WD My Cloud that is necessarily at fault but the particular router/gateway AT&T is providing its customers. I hope you are complaining to AT&T with the same vehemence you are complaining here about WD. (And for the record I am not a WD employee.)

In any case the solution as unpalatable or unacceptable as it may be to you is simple until AT&T provides you equipment that doesn’t conflict with the My Cloud; use a switch, hub or spare router. If not or that is unacceptable to you, then return the My Cloud and move on to some other device.

Trust that AT&T has heard their fair share of earful regarding issues with their service. AT&T, however, didn’t lead me to believe their product worked with any cloud drives, so your assumption is incorrect. In addition to posts here, there are posts on the AT&T forums. “Few posts” doesn’t mean many more don’t have the problem, speaking of clues.

WD did lead me to believe their product was “Compatible with PC and Mac computers | Works great with all the PC and Mac computers in your home, right out of the box.” I see no mentions anywhere, except these and the AT&T forums, that there may be this sort of issue or that additional equipment may be required with various networks. That’s why I picked this product. I went through every troubleshooting checklist item WD provided here until it got to factory resetting my router, which certainly makes “out of the box” a bit more time consuming, and I’m not doing it.

I don’t think it’s too much to expect the product or service for which I paid, without hidden extras.

Point being I wanted WD to know I’m dissatisfied and other people stuck with AT&T to understand this is not an out-of-the-box, 5-minute setup.

Done here. But thank you for your interest in my rant, Bennor.

You’re right; it is ridiculous.

Sadly, neither AT&T nor WD seem to think it’s economically worthwhile to spend engineering time trying to get to the bottom of it, or warn their potential customers there may be an issue, or modify their support systems to flag this problem early. Both seem to be blaming the other.

As for sending your device back, well, it won’t be to us; we’re almost entirely customers here, and WD staff rarely make an appearance. So your entirely justified rant is unlikely to be heard by anyone from WD.

My assumption, as a former multi year customer of AT&T DSL/Uverse is not incorrect. When one signs up for broadband service and receive the equipment to access that broadband service we have an expectation that said equipment (by AT&T for example) would work with ALL of our network equipment regardless of manufacturer or when purchased. AT&T rant, one of many, time: In my case I discovered only after being issued an AT&T Uverse gateway that I couldn’t put it into bridge mode, something my previous AT&T DSL router was capable of. That turned my personal router that I had used for years without issue, into a dumb switch. Even now under Frontier I cannot modify certain Frontier provided router settings (DNS) which causes occasional Netflix problems with my Roku boxes.

It should be noted that if one does an internet search for “wd my cloud at&t uverse” the very first search results are typically showing that there is a problem with Uverse and the My Cloud. Further in the past other NAS manufacturers have had problems (like some Synology users did with sleep mode) with certain AT&T router’s. Like in your case the solution was to put a switch/hub/second router in between the AT&T router/gateway and the NAS.

By and large the My Cloud does work with most Mac, Windows and Linux computers, and with most broadband router/gateway units. The reality is that WD nor AT&T nor any other manufacturer can be expected to guarantee their equipment will work 100% with the tens of thousands of different manufactures and product models that exist. It is simply prohibitively cost ineffective to test against every single possible variation or product that is introduced.

Like cpt_paranoia indicated neither AT&T, who is supplying their customers a specific router that is causing the problem, nor WD seem interested for what ever reason in resolving this issue, or at least publicly providing information on how to solve this issue. As indicated above a quick internet search would have informed someone who is interested in buying a My Cloud for use on AT&T broadband service that there is a potential conflict depending on which router AT&T provides being discussed in both WD’s and AT&T’s user to user support forums.

As previously indicated this need to use a switch/hub/router with a My Cloud appears to be an issue confined primary (if not solely) to the use of one specific model of AT&T router/gateway and not other broadband providers.

Thank you for that heads up regarding WD not frequenting the forums, cpt_paranoia. I’ll be sure to pass my feedback to them directly, as well.

Sure seems like they’d have an interest in ensuring their equipment worked with current /newly installed equipment for a company like AT&T! Then again, I gave AT&T a specific needs list, and they failed me on multiple levels. Whatever happened to companies caring??

Yet another AT&T customer blaming WD for their AT&T problems. I have read plenty of these complaints on these forums, and know darn well that if AT&T ever came into MY neighborhood, I would avoid them. Problem is, most of us are stuck with one provider – ISP choice is non-existent in many cases. I have had Comcast in my current home for over 12 years I have been here, I have another ISP choice called Frontier (previously owned by Verizon), but Comcast has treated me well ,and EVERY device I have works well with it; including a My Cloud DL2100 high-end NAS.

My advice to OP: if you can DUMP AT&T for another name-brand ISP, DO IT!

PS, I have always owned my own router and modem, and for good reasons.

I followed Bennor’s google suggestion, and the third hit that came up was a thread on an AT&T forum, where someone had found a solution on a Sonic forum (provided by a ‘customer experience manager’; that’s a hint, WD and AT&T, on how to engage with your customers).

The answer may be to SSH into the MyCloud and force the Ethernet link rate:

ethtool -s eth0 speed 1000 duplex full autoneg off

(I’ve changed the rate to gigabit)

He then rebooted the MyCloud, so the setting appears to be persistent.

But note Tony’s warning:

I suspect this will only work on the v4 firmware, as the v2 seems to re-load its firmware on reboot.




I don’t have AT&T, so I can’t try this, but if someone can confirm it works, I’ll post the fix on the most popular MyCloud forum thread.

Adding a switch to your system can give other benefits, but it shouldn’t be necessary.

You would think one would same about AT&T. That AT&T should have a interest in ensuring their routers/gateways work with all consumer equipment like WD My Clouds!

Its easy to blame WD rather than AT&T or some other company who’s product conflicts with the My Cloud. Most people blamed WD when their My Cloud stops working properly due to an issue related to a specific AT&T Uverse supplied router, or when one upgraded their Mac to Apple’s El Capitan, or when Microsoft rolled out a Windows 10 Update that cause SMB problems with many NAS boxes not just the My Cloud.

Unfortunately AT&T nor WD has provided a public response/answer as to the cause and a solution to the issue. Instead people are forced to rely on using a switch, hub or second router (edit to add: or as cpt_paranoia indicated above SSH) to fix the network communication issue introduced by the AT&T Uverse router. This issue is limited to so few customers (of both products) that AT&T or more specifically their equipment vendor(s) and WD probably feel it is not cost effective to spend their limited time/money to solve the problem (if it can be solved at all) with their products.

Interesting to solution to an issue introduced by the AT&T supplied (Pace?) router. Part of the problem here is typically one cannot modify the firmware of their broadband ISP provided router/gateway like they can with the My Cloud or one may not be able modify the link rate of the network port within the broadband provided router/gateway. So if forces the user to use SSH on the My Cloud rather than adjust a setting within the router that introduced the issue.

Hopefully some can report back who has the problem if this works on their My Cloud. It would be interesting to see if someone who is having these problems could experiment with their AT&T supplied router to see if it has an option to change/modify the link rate on its networking ports and if that fixes the communications issue with the My Cloud (and possibly other local network devices).

Yes; my original suggestion was to look at the router settings, assuming it was an auto-configuration problem. But I’m not with AT&T, and don’t have the offending Pace 5286AC modem… I think I’d prefer to change the port configuration on the router, via its UI, rather than delve into Linux via SSH on the MyCloud… But if the router’s UI isn’t rich enough to control port auto-configuration modes, I guess it’ll have to be done at the MyCloud end.

Well, we don’t know which end is failing the MDI/MDI-X protocol. It seems to be an unfortunate combination of the two products, since they both seem to work okay with other devices. Some subtle interaction between their implementations of MDI/MDI-X.

Yes we don’t know which device is ultimately which device is at fault. But the fact remains that some people had a working My Cloud until their AT&T premises equipment is changed out by AT&T (or one has a new Uverse install) to the Pace/Arris router/gateway then the My Cloud stops working. They use another router, problem goes away. Of course the standard knee jerk reaction by most is to blame the My Cloud rather than the AT&T equipment (or Apple or Microsoft…).

I guess my past multi year history in dealing with AT&T both on billing issues and their broadband routers/gateways colors my view and its why I’d put the blame on the AT&T/Pace/Arris router first rather than the My Cloud. :smiley:

It’s the Arris router on U-Verse, and I don’t really have much choice regarding Internet service provider here. Again, it’s not like I’m using some little-known provider in a corn field somewhere (not that I have anything against corn fields – I grew up in the Midwest).

I could see the MyCloud device in my router config, change the IP, set port forwarding, blah, blah. I also have other devices on the Arris, including cloud-based cameras, and they work fine. So, yes, I’m blaming WD and not AT&T, with full knowledge that AT&T is usually my problem child.

Yesterday, I remembered we had an Ethernet switch lying around unused, added it between the Arris router and the MyCloud, and it was discovered. I went through set up. I mapped drives. All seemed well. I ran robocopy overnight, and files were copied. I could access the mapped drives in File Explorer. It was still there when I went to the computer this morning.

Then I moved my laptop from one room to the next, losing Internet connection, and inadvertently unplugged the Arris. When everything came back up, the WD MyCloud set-up page couldn’t be found again. My mapped drives appeared, but only after I reset and unplugged/plugged in the MyCloud. I’ve tried multiple browsers, and I still can’t access the dashboard. I know the thing is there, because robocopy is accessing the drive right this minute (post MyCloud reboot). I installed the WD Access software, and it says it’s ready to use. The Arris says it’s on the network.

But, I cannot access the dashboard via IP, the setup link, or the name I’ve given the device, and, had I not mapped drives last night, I’d not be able to access anything at all on it.

I suppose this is AT&T’s fault too, eh?

Regarding WD not visiting the forums, apparently they lurk: I received an email regarding a support ticket I never opened and am thinking it’s because of my post here.

Did you try forcing a fixed link rate and turning off auto-negotiation as suggested above, rather than using the switch workaround?

What exactly do you mean by “couldn’t be found again”?
Did you get any response?
Did you get a page not found?
Did you get a dead Dashboard page?

Did you close the previous Dashboard web page, and open a clean one? Sadly, the Dashboard contents can be cached by some browsers, and you get a “lights are on, but nobody’s home” response.

Did you set the router to always assign a fixed IP address to the MyCloud (infinite DHCP timeout/lease)? If not, a router reboot may have re-assigned the DHCP address for the MyCloud, and your router’s DNS may not have caught up with the change yet.

I don’t know whose fault it is, because I don’t know what is causing the problem.

I don’t think anyone has said WD are perfect; far from it. Look around my posts on the forum and you’ll see I give them a hard time a lot of the time. But I try to be fair, and allocate blame where it lies. The problem with auto-negotiation is down to both WD and AT&T (as I’ve pointed out consistently on this thread and others); both their products work fine with other products, but for some reason won’t work together.

The moderators often refer queries to WD Support. Moderators are users, too, not WD staff.

We’re trying to help. The MyCloud is a pretty complex, imperfect beast. Add the vagaries of home networking and you can have trouble. It can be made to work, but it does require a bit of effort; I’ve learned a lot about Linux, file systems, Window networking, SSH, networking & routers, media servers, etc since buying the thing and coming here for help. It’s a shame that WD can’t sort out some of the problems, but then I bought both of mine at less than the price of a bare WD Red HDD.

Well you did admit you inadvertently unplugged the Arris then you lost access to the My Cloud when you powered the Arris back on, so yes it could be entirely possibly it is the fault the Arris router. Or more likely its possible if you didn’t configure the My Cloud for a static IP, or configure the Arris to reserve an IP address for the My Cloud that you could potentially loose access to the My Cloud. We see it time and again where someone resets or reboots their router and the non static IP address My Cloud obtains a different IP address from the router; causing their drive mappings to fail/break, causes the My Cloud Dashboard to become inaccessible and other programs to fail to find the My Cloud.

Don’t know if you’d indicated yet but what is the exact model name of the Arris router?

Have you tried as cpt_paranoia previously suggested to see fi you can force a fixed link rate and or change auto-negotation for the network port on the Arris router the My Cloud is connected too?

On my Arris NVG589 (formerly from AT&T) the Home Network > Configure page one has the option to force, by individual network port, the link rate and MDI-X. Example:

On that Arris page the “Help” field it indicates that the “Auto” setting for Ethernet (link rate) is set by the client. It ts possible the hardware or firmware driving your particular Arris router network port has a problem with the hardware/firmware driving the My Cloud network port and changing the Ethernet/link rate setting could fix the conflict/issue.

WD nor AT&T are liable to address this problem no matter how much you and others complain about it. This issue has been well known in both support forums for many months now. Its entirely possible the problem could be hardware related either in the Arris router or the My Cloud. So far I don’t recall anyone having a similar problem with any other ISP’s router/gateway other than the one or two router/gateway’s AT&T is providing to its Uverse customers.

The My Cloud is what it is. And it has its share of general problems which many, including myself, have complained about. WD hasn’t addressed many of those complaints even though they’ve been around for years. One can see many of those complains/suggestions in the Cloud Ideas subforum.

In most cases there are solutions or workarounds to many of the common/general problems or issues raised in this subforum and with the issue you are experiencing. Those solutions/workarounds may not be elegant, easy to configure, or cheap to fix, but that’s the nature of the My Cloud, and often other networking hardware. Should we users have to do some of those workarounds/fixes just to get the My Cloud to work as advertised? No. But this is the nature of many electronic devices, they don’t always work 100% as advertised or as the customer expected (or assumed). The simple reality is that there is no guarantee that a network enabled product will work 100% with every single; router, modem, switch, etc. that has been made or will be made.

Moderators are WD staff, not users. Note their tag next to many of their names. Moderators also can ban abusers from the forum, as well as do other things. Bill S is the admin of the forums.

The My Cloud/AT&T issues originate from AT&T. No doubt about that. No other ISP has these issues. The Arris (aka Motorola) modems are highly regarded; I have one I originally purchased (Motorola) It may be the combo modem/router that is a problem, or the way it is configured internally our actually the AT&T configuration at their mother ship… I have been connected to the Arris combo units, at friends and family, and I can easily reach my MC NAS remotely from these units – but they are not connected to AT&T either. Usually connected to Comcast.

Without copying and pasting every note above:

  • I did NOT mean to be snarky with you, cpt_paranoia – I know you’re trying to help. I apologize that I wrote my comment in a way which made it appear to be directed toward you.

  • Regarding my “AT&T’s fault” comment, two people are implicating AT&T, but I can see/use/access every other device on my AT&T-based network, regardless of router reboots. So some say “only AT&T users have this problem” while I say “this WD device is the only one giving me fits.” So, again, I’m not going to blame this fiasco on AT&T.

  • I DID try forcing the fixed link rate, but, as you can see from Bennor’s screen shot, which accurately reflects my router, autonegotiation isn’t something I can turn off with the Arris router. Forcing link rate didn’t help.

  • Yes, that’s the Arris router I’m stuck with.’

  • It was not an IP address issue, in the traditional sense of the MyCloud obtaining a new IP (see note below). I had set it and knew what it was. I triple checked my router config screen (refreshing in between) and it showed the IP I assigned AND I pinged it, and it came back as expected.

  • “Couldn’t be found again” meaning the Dashboard was throwing 404s, Forbidden, and timeout errors (it switched between errors on refresh in the browsers I tried). But the mapped drives appeared in File Explorer. I knew it was there, but couldn’t get the dashboard.

  • I cleared my Chrome cache AND tried Opera, Safari, IE (no comment), and FF.

  • I’m not “sharing” the MyCloud or its folders (by design – no one else on my network should have access), so I couldn’t go to Network > Right Click > Open in browser (as noted in other posts).

Here is my bottom line, after much frustrating troubleshooting; hoping it may help someone else who’s stuck and, though you three responding don’t need the explanation simplified, it may benefit someone else:

This may help if:

  1. You can’t access the MyCloud Dashboard (but you could yesterday or last week) AND
  2. You have AT&T U-verse with a block of static IPs AND
  3. The device from which you’re attempting to access the Dashboard is set to use a static IP from the AT&T paid-for pool AND
  4. You’re getting Forbidden, 404, or timeout errors from the device using a static IP from the AT&T paid-for pool AND
  5. You’re able to access the Dashboard from another device on your network which is NOT set to use a static IP from the AT&T paid-for pool

I was recently forced to “upgrade” (term loosely used) to AT&T’s U-verse service from DSL. Following installation, it was disclosed that AT&T had redefined what “static IP service” is. So, where all devices on my prior DSL home network used to register (when searching “What’s my IP,” for example) the same IP address, like this…

  • Desktop: xxx.xx.xx.0
  • Laptop: xxx.xx.xx.0
  • Tablet: xxx.xx.xx.0

… Under U-verse, if IPs from the U-verse static, paid-for pool are assigned to your desktop, laptop, and tablet, your devices register like this, for example, instead:

  • Desktop: xxx.xx.xx.1
  • Laptop: xxx.xx.xx.2
  • Tablet: xxx.xx.xx.3

Somehow, the router knows you’re still on your home network, and you CAN access your networked devices which use IPs which are in the auto-assigned range from to

That is to say you can access everything except your MyCloud device. It seems to think you’re outside of the network and when you attempt to access the MyCloud Dashboard you’re getting a 404 error or Forbidden error or Timeout error (or changes from one of those errors to another).

When I reset my laptop to use one of the DHCP Allocated IP addresses instead of one from the paid-for pool, restarted my router, (laptop now assigned a network address of, went to the MyCloud assigned IP of, the Dashboard appears. It also now appears when I go to http://cloudname/.

I’ve seen posts which say to set the MyCloud device outside of the DHCP pool, but the router doesn’t give me that option, so I don’t know if that’d work. I’ve seen posts which say I need to set an IP and port forwarding for MyCloud, but I don’t want to open a port for the MyCloud device and, if I understand correctly, port forwarding is for the purpose of accessing from OUTSIDE my home network (and, in fact, that access doesn’t work from INSIDE the network) – I have no desire to do that, in any event.

The bottom line is to check your IP from within your router configuration settings. If it says the device you’re using (laptop/desktop) is on an IP that doesn’t start with the same router-specific xxx.xx.xx IP as the MyCloud device, try changing the IP of the device (laptop/desktop) to match the first three segments. So the laptop/desktop should be xxx.xx.xx.ANUMBER and the MyCloud should be xxx.xx.xx.ANOTHERNUMBER. If your laptop/desktop is yyy.yy.yy and the MyCloud is xxx.xx.xx, the MyCloud doesn’t seem to want to let your laptop/desktop in.

I need a static IP for my laptop, so it appears I’m going to have to switch from self-assigned to router-assigned whenever I have to access the Dashboard. Unless someone knows a way around it.

Thank you for those trying to help.

Some moderators are WD staff, Bill_S in particular.

Others aren’t; I’m pretty sure that @Trancer and @ERmorel are users.

My Asus router assigns IPs via DHCP I have never set, not do I have any static IP for any device, and all 30+ devices on network work fine. Although, because my router assigns a permanent IP for each device based upon an algorithm created from each device’s MAC address, perhaps in a certain way, maybe I do have a “static” IP, but the router is set to use DHCP.