User Name and Password prompt when attempting to access Public folder

I am using Acronis True Image 2018 and am attempting to perform a recovery from a My Cloud Home NAS using True Image boot media (WinPE-based media using the “Windows Assessment and Deployment Kit (ADK)”). Similar to this post: Asking for username and password when using EasyUS Todo Backup - #3 by multimedium, I am being prompted for a User name and Password, even though within Windows 10 the “Public” folder does not require a User name and Password. The only credentials related to the drive are the email-based User name and password used to access the drive remotely via the WD site or apps. That account information doesn’t work for this login prompt. Since I am unable to successfully login, I receive the error:
“\Mycloud-xxxxxx is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.
The Server service is not started.”

I have also tried generic user name/password combinations (admin/admin, guest/guest).

Any help would be greatly appreciated.

Have never seen or experienced this before with Acronis, but try (nobody/nobody) which is the Android (Linux) equivalent to (guest/guest) on Windows.

Thank you for your response.

OK, I have now tried nobody/nobody as suggested (also tried nobody/blank) but I still receive “Connection failed. Please verify user name and password.”

What would you suggest to try next? Fortunately, I have the ability to wipe the data on the My Cloud Home drive if need be, since the data on the originating PC is still available. So, a reset to the My Cloud Home drive is an option if that would be worth trying?


I have now performed a full reset to the My Cloud Home drive, as described here: How to System Erase My Cloud Home to Factory Settings

Then I followed the initial setup process of going to My Cloud Home and signing in with the existing MyCloud account.

Then created a backup image in Acronis True Image from scratch to the drive once again.

After booting into the True Image recovery interface I receive the same results when attempting to access the My Cloud Home drive from under “Network” (using various user name/password combos): “Connection failed. Please verify user name and password.”

I ended up needing to map the drive from the command line, as suggested on the Acronis forums. I had to also include the generic user name/password, as suggested by SBrown above:

net use x: \ Mycloud-xxxxxx\Public /user:nobody nobody

Thank you for the help!

Two years later, new WD My Cloud Home user and I am having this exact problem. Wanting to test the free trial of Acronis True Image 2020 Mac. True Image app sees the WD device as a destination for the backup and accepts my username(email)/password combo to select it. But then it also wants me to enter a username and password to select the Public folder. The same email/password doesn’t work and I have no other credentials to try. Choosing Guest does not get me in, either. It fails the same way.

The solution you described 2 years ago means nothing to me. I’m a Mac user and not inclined to go messing around in Terminal (Mac equivalent of Command Line).

Any other ideas? Guess I’ll have to poke around the Acronis forums. Or try a different backup scheme.