Useless My Cloud

I’ve had a WD My Cloud replaced as my previous one stopped working after being set up.

The replacement has now stopped working.

Blue light is on solid.

I can access via the dashboard but not via the desktop app.

Any help would be appreciated as WD Customer Support seem a bit clueless.

More information is needed. How is the My Cloud connected to the local network, how is the computer connected to the local network, have you tried a 40 second reset, who is your broadband provider, what operating system are you using, have you tried using the IP address of the My Cloud for access, what other troubleshooting steps have you tried?

Connected directly to my Mac via ethernet.
40 Sec reset done.
BB Provider: Virgin
osSierra 10.12.3

Generally one connects the My Cloud to their local network router (or switch/hub). If one is using a Pace, Arris, Ubee or Sonic Gateway Router provided by their broadband provider one may experience issues where the My Cloud isn’t found or other issues.

Generally one uses Mac Finder to access the My Cloud. Have you tried using Mac Finder? Have you read through the My Cloud User Manual ( Or reviewed the My Cloud learning website(s) for additional information on how to use the My Cloud?

Mapping the My Cloud to the Mac makes it easier to access the My Cloud.