USB not Recognized for My Book Essential?


I have had my 3 TB 3.0 Essential hard drive since black friday. I have used it almost everyday until yesterday when i turned my computer on, it did not recognize my hard drive. It gives me USB not recognized but it worked for the past 3 months. Does anybody know what i can do since it used to work.? it doesnt work on my laptop either. DESPERATE FOR ANSWERS.



I’m having the same problem.  I’ve tried placing your USB in other ports, my desktop, all 3 laptops, but still giving me the message that it is not being recognized.  What to do?  Anyone?

I went to my Device Manager.  Found the USB controller and updated the drivers there and still nothing helped.  Why isn’t it working?  Why are so many people having trouble with Western Digital products? 

According to a reply to the same problem to someone else’s post, I changed out the data cable with one that is good and it worked.  Replace your old data cable first.  For those that don’t know what that is, it’s the cord going from your external storage device to your computer.

I don’t what happened but I completely powered down my computer, unplugged HD then started the computer up, once it completely loaded I plugged the power cord in, made sure it was running then Plugged the data cable back in the HD and plugged it into a USB port I knew was wOrking! And it magically worked.