USB Backup Failure - settings question

When will the ‘–timeout=30’ be eliminated? Or, if it cannot be eliminated, then increase it to 600 (10 minutes) or 1200 (20 minutes).

Reading the rsync man page shows:

This option allows you to set a maximum IO timeout in seconds. If no data is transferred for the specified time then rsync will exit. The default is 0, which means no timeout.

So, if you have a large number of files, it is certainly likely that the command will fail. That’s because rsync builds a list of files before it transfers and if that building takes longer than TIMEOUT, no data transfers and rsync gives up.

Seems like an easy fix…

Yes I read all the above comments and complaints. I have the exact same problems. Even after handing mycloud mirror device back to WD under warranty and getting a new device the same problem arises in backup failed. I want to sync the external passport to my already COPIED back up as I keep putting new music on my passport. So its when I SYNC is where the problem arises BACKUP FAILED

Has anyone in here ever tried the Synergy Server ??

I have not tried Synergy Server. I do not use the EX2 for sync or back up. It just sits there as a storage device. I pt the smarts elsewhere on my network. I gave up on the EX2 a year ago. What I did was take an old Windows pc that was about to be retired and created a windows storage space which is fault tolerant. . I gathered up every old hard drive I had, ( big and small) and added them to the storage space. I ended up with a storage space far larger than the EX2 box. I installed a back up software on the windows box and now it synchronizes to the EX2 box all the time. So now I have the EX2 that everyone on the network uses for storage and an old windows PC sitting quietly in the corner that has a copy of everything on the EX2. This has been working flawlessly for the past year. There is lots of freeware programs out there that do the backup and sync for you…

hi all,
getting back to the original question: has WD ever fixed the problem or clarified the right settings to back up to a USB drive?
Here we are in 2018 and I am still having the same issues.

Hi, this problem still exists. I was battling with this yesterday. Got a MyCloudMirror and a new USB3 drive.

I need the option of read and write from/to Windows and Mac so formatted the USB drive as FAT32 (NAS doesn’t like ExFAT).

Wondering now if it’s simply down to the FAT32 file size restrictions or folder depth.

May have to bite the bullet and do a host backup over my LAN via my laptop to USB drive. Will know in a few days…

For everyone coming to this necro thread from Google:

What worked for me was plugging the hard-drive (Seagate) into a PC and formatting it (NTFS). Then I deleted the old backup job on the WD Dashboard and created a new one, making sure to select synchronize NOT copy.

For whatever reason the old backup from the WD on the Seagate had switched to “read only” and couldn’t be deleted or overwritten OR made editable, even from File Explorer, but I could format over the top of it in Windows. However, trying to format over it as exFAT on a Mac failed.

Our office has multiple HDs, so using File Explorer to copy/paste backup onto a spare HD so I’d have something while I tinkered with the Seagate wasn’t an issue.

I have no idea if it was the “fault” of the Seagate or the WD that that folder became immutable, but, there you have it.