USB 3.0 Passport drive does not support usb 3.0

Very slow transfers. I started to investigate.

W10 Pro 64 bit.

Passport is connected to a 7 port USB 3.0 hub, which is in turn cabled into a USB 3.0 PCI card as my PC is USB 2.0. Also on the hub is another external drive, a Samsung M3, also USB 3.0. Crystal Disk Mark shows much better figures for the Samsung than the Passport.

I then discovered the MS utility, usbview.exe, which shows large amounts of information about the drive. Including whether it supports USB 3.0. According to this programme, the Samsung does but the Passport does not.

Which suggests I have been sold a pup… I have logged a support ticket but heard nothing bar an acknowledgement email.

Pretty strange, all actual Passport support USB 3.0.

Do you use the USB cable that was shipped with the Passport drive?
Are you using a dedicated USB 3.0 port on this hub? USB 3.0 ports have to have blue color inside.

What result do you get if you run the same test without the hub (just connect each drive individually to the PCI card in turn and re-run it)?

As @Joerg_A says, all current MyPassport drives support USB3.0.

1 Like


I intend to test this next time I shut my PC down. As noted, there is a Samsung USB 3.0 drive on the same hubm which is recognised as such. Watch this space.

Strange indeed, and yes, it is the cable supplied with the drive, and it does have the SuperSpeed symbol on it.

Is it a so called active hub with its own power supply? Background: possible power issue on the USB ports if several USB 3.0 devices are connected…

Each USB 3.0 will request 900 mA USB bus power, if this 900 mA cannot be granted by the port (or the hub), it swicthed down to USB 2.0 aka 500 mA.

Yes, it has its own power supply, as I have had problems with that before.

Next step: what happens if removing the Samsung drive and then attaching the Passport drive? Still states USB 2.0 instead of USB 3.0?


Next time I shut my PC down I’m going to try a few different combinations - straight into the PCI card, as suggested above, and without the other devices on the hub (a keyboard and a Samsung). Watch this space!

1 Like

Strange. I got a My Passport Wireless which on USB3 would definitely want 900mA or more only gets 500mA yet works at USB3 speeds. Unless it is the hub?

I wonder if the hub switched a port to USB2 because there was insufficient resources to run it as USB3?

Slightly off-topic, PoE switches do something similar. They can only provide a finite amount of power between the ports and when the capacity is reached al the other ports used will operate as standard network ports.

1 Like

yes, correct. If the overall power budget is reached, then PoE swicthes and USB hubs a) lower done one gear or b) reject new devices to be powered by the bus or port.

I assume something similar here, the USB power budget of the USB hub may be insufficient to support multiple USB 3.0 drives.

Well, it has a mains power supply, and as it is a seven port hub, one would hope that the manufacturers would make sure that all ports could operate at 3.0. I have to leave now, but I will upload the usbview output for both drives on the hub, you may be able to make more sense of it than I can, all I can note is that for the PASSPORT, it says this

[Port3] : USB Mass Storage Device

Is Port User Connectable: yes
Is Port Debug Capable: no
Companion Port Number: 3
Companion Hub Symbolic Link Name: USB#VID_2109&PID_0812#7&337684d4&0&1#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
Protocols Supported:
USB 1.1: yes
USB 2.0: yes
USB 3.0: no

and the SAMSUNG this

[Port2] : USB Mass Storage Device

Is Port User Connectable: yes
Is Port Debug Capable: no
Companion Port Number: 2
Companion Hub Symbolic Link Name: USB#VID_2109&PID_2812#7&3ef6c4a&0&1#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
Protocols Supported:
USB 1.1: no
USB 2.0: no
USB 3.0: yes

Thanks for your help

If you like to share this information, please send the article name and manufacturer of your USB hub to let us find some more backhround information about this hardware.

Will do, have to be later - thanks

1 Like

Joerg - here’s the details of the hub 7 Port SuperSpeed USB 3.0 Hub - Desktop USB Hub with Adapter

@Jeremy_Poynton - What is the model of the drive?

This is the model

WD My Passport Ultra

@Jeremy_Poynton - Thanks - could you just also verify the model number on the device itself? I just want to be absolutely sure we aren’t somehow working with a 2.0 drive.

Have you tried with the passport directly to the computer? Have you tried it on a different computer? With a different USB cable?

Well, it’s sold as 3.0! Just let me get a torch and magnifying glass! I can’t read the numbers on the back with the naked eye
On the back - p/n WDBZFP0010BBK - 05
- s/n [Deleted]
- 2515B
- r/n D8B DDAKHA

that of use?

Ok - that is the correct drive… (I removed your s/n from your post - you should keep that one confidential except when dealing with WD Support).

What were the results from the stuff I suggested in the post above? If you get the same result with a different cable directly connected to a different computer than something is likely up with the drive and you should replace it. If the issue corrects itself than the problem likely isn’t the drive itself and we need to do further troubleshooting.