[URGENT] My Book Essential no longer can be accessed ! HELP ME PLSSS!

 I am using My Book Essential with USB3.0 + USB2.0 with 2TB.

My Book is working well all the while but suddenly cannot be accessed yesterday and it requires me to format it !
It does display the drive letter that used to appear under My Computer but it does not display the size of the hard disk and it cannot be accessed.

I can be sure that the problem is not about the power adapter or USB port since the drive still manage to show up in the Disk Management.

Any methods that I can recover my files without formatting the drive ?

I used to plug in my device in USB 2.0 ports so it shouldn’t be any problems for USB.

it displays such an error message to me:

I:\ is not acessible.
The parameter is incorrect.

please help me !!!

First look in disk manager and make sure it still has a drive letter. If it shows in Disk manager delete the driver disconnect the drive reboot and try the drive again. some people have had luck with this Test Disk http://www.techsupportforum.com/forums/f16/my-file-system-is-now-raw-help-192014.html


I have a similar problem.  Today, the drive does not seem to be recognized (no drive or letter assigned or drive visible in windows XP explorer).  When I unplug the drive I get a beep and when I plug it back in I also get a beep.  When I do the test hardward, says drive is functioning fine (but can’t see it).

Maybe I’m off on the wrong foot.  I’ve used the 1TB for quite some time and love it, for the 2 TB, problems with the backup software bringing my PC to a crawl even when not doing backup.  Today, would love to have that problem.

When I tried on a 2nd PC, I received the windows (XP) found new hardware.  I let it do it’s thing, which maybe I shouldn’t, but same issue on the other PC.

When the 2 TB drive is plugged in, both PC’s will not boot properly, so the drive is doing something.  When I unplug, the PCs will reboot fine.

Is there a driver or something that I could uninstall and try reinstalling?



Noooo ! it still no work ! I have tried the Test Disk but the drive still appear as RAW file and it display:

F:\ is not accessible.

The file or directory is corrupted and unreadable.

Help me please !!!

Right click My Computer, choose “manage”. Click Disk Manager. Check out your drives from there.

Is F: PART of your physical disk, or does it have it’s own section just for itself?
You should see 2 main bars split up with your partitions. And and another bar(s) for CD-ROM drives. If there is a bar for F: all by itself, then it’s  some kind of other drive your system has.

If F: is alongside the other letters, well just give us the details, or a screen shot of Disk Manager

Another thing to try

run a check disk:


Sorry, Lawrence, I wouldn’t run checkdisk.  People have be reporting that it makes things worse. 

@ noname2188,

If the drive shows up in Disk Management, but not in “Computer,” then you may have either corrupted some of the data or damaged the patition.  You can try plugging directly into a wall socket to make sure you’re getting enough power to fully spin up the drive, but it shouldn’t show up at all if it’s not getting enough power.  If the drive shows up in disk management, and from what you said about trying it on another computer, it appears that you have data or partiton corruption.  You can try looking on the internet for some data recovery software that will restore partitions, and see if that helps you.

Data corruption can happen  a few ways: 1) by just pulling out the cable without safely removing the drive; 2) copying data over that’s corrupted; 3) bad or damaged cable; 4) power failure while copying data to the drive; or 5) by some type of hardware failure that inhibits data transfer - could be a port, drive board, etc.

1 Like