Upload Speeds are Slow when accessing MyCloud on the go

I have a MyCloud with the Firmware 2.30.172 hooked up to my AVM Router. My internet connection is 109mbit/s down and 42mbit/s up. The ethernet port is 1Gbit/s.

When I am transferring files to and from the MyCloud at home I get normal speeds at around 110MB/s. So it’s not the ethernet connection that is slowing it down.

When I am on the Go and I want to download files from the MyCloud I get speeds that max out at 15-17mbit/s, even though I am connected to 4G+ that constantly gets between 200mbit/s down and 80-100mbit/s up. Also tried it on a friends computer that has about the same internet speed at home as I do and still the same speeds.

I am located in Germany but that shouldn’t change anything when it comes to the MyCloud.

Anyone has an idea as to why I only get half of the download speed of my actual upload speed at home?

And no, there aren’t any other devices connected to my router at the time of testing. Firmware is the latest on the MyCloud, everything is set up perfectly fine. Standard settings in the MyCloud are enabled, I never had an issue connecting to the MyCloud, it’s just the speed that I am getting from it is what’s bugging me.

Thanks in advance and merry christmas everybody!!!


This is a combination of your home internet pipe being asymmetrical (only 42mbit UP), protocol overhead, and ISP throttling.


Your mycloud is UPLOADING to you, when you request a file from it from remote.

Your ISP does not really want to service you at the full 42mbit upload speed.

There is some overhead relating to resending datagrams over a busy medium, like the internet, should there be contention, buffer bloat leading to dropped packets at backbone routers, occasional packet collisions in transit, and of course, the unforseen. (which is why TCP exists to begin with.)

There may be overhead in whatever protocol the proprietary WD software uses to broker the connection.

1 Like

Thank you for your quick response!

But 60% loss is quite a bit. I hooked up an external HDD to my USB port on my router and set it as a NAS and I get download speeds about 37 to 38mbit/s no matter where I am at. It is simply the MyCloud that is so slow. I would expect a drop of maybe 10% max due to the things you mentioned, but 60% makes me blame WD or whatever is causing the MyCloud to be this slow.

And about the ISP throttle… I always get my 42mbit/s when I am at home uploading stuff to YouTube or sending files to friends. I could sue my ISP if they wouldn’t give me the speed that I am paying for all the time. They are guaranteed speeds.

One would expect that a device that is solely made to store and access files from the internet would be the best solution for all your storage needs at the best speeds, but a 25 Euro HDD hooked up to my router is the one that’s performing as the MyCloud should.

I am curious if you are using the mycloud’s ‘cloud’ functionality (which uses a stateful connection to a WD server the mycloud establishes, to broker the on-demand session using a proprietary daemon running on the mycloud), or some other means of accessing the data. (tunneled SMB, HTTP, FTP, NFS, SFTP, or something else)

I ask, because you mention a USB device sitting on your router being accessed from remote as well.

This either implies apples and oranges (Some protocol other than WD’s remote access protocol being used on the USB device attached to your router, and WD’s remote access protocol on the mycloud), or some kind of setup I have no idea about.

Oh I should have been a bit clearer about it.

I hooked up my USB HDD to my router once to see if it would be as slow as the MyCloud when accessing through the internet. I never hooked it up before and it isn’t hooked up currently.

I access the MyCloud through the MyCloud Android app. I also tried to connect to it via my browser on my phone and I get the exact same speeds as through the app. Also tried my Windows 10 tablet hooked up to a connection above 100mbit/s and still get the same slow speeds for the MyCloud but got nearly full speed for the USB HDD. I accessed my USB HDD via the AVM routers built in app which gives me the option to access my router remotely through the internet. Kinda like the same concept behind it as the MyCloud.

It just bogs my mind that the MyCloud service is that much slower, and it isn’t because my internet or the way it is connected is bottlenecking it.

These are the settings the MyCloud is running on.

Ok. to understand why there is a drop in performance, consider how the connection is being handled.

In a normal transaction, a client connects directly to a server, handshakes a connection, and then starts getting data.

Client <–> MyCloud

In the case of the mycloud, since the IP addresses of both the client, and the target server (your mycloud) are unknown (dhcp being what it is and all, as well as the existence of stateful NAT firewalls), your Mycloud works through an intermediary that is known, as does the MyCloud App.

Client <–> WD Server <–>MyCloud

This is accomplished via a daemon that runs on the mycloud that connects to the WD server application platform, and identifies itself with a unique ID. (“Hey, I am MyCloud number BLAH BLAH BLAH! I am ready to receive access requests!”) Since the mycloud lives behind a NAT firewall (your router), it has to initiate this connection itself. WD cannot access it on demand from remote without this connection already being active. (research stateful connections)

Your client then connects with the known WD application server, and says “Hey, I want to talk with MyCloud number BLAH BLAH BLAH! I have these credentials, please connect me!”

The WD server then issues a challenge to the MyCloud it has connected to it, asking “Are these credentials good?” The connected Mycloud says “Yes, those are good credentials.” The WD server than says “Ok, Send me this file…” The mycloud sends that file to WD, and WD forwards that data to you.

This is because WD is functioning as if they were a VPN tunnel provider, using their proprietary (encrypted) protocol to transfer the data.

A more sensible way they could have done this, is to have the mycloud directly handshake with the remote client, by providing the mycloud with the remote client’s IP address, having the Mycloud initiate the handshake (since the outbound connection has to originate from the mycloud to establish the stateful socket connection through the nat firewall), and then have the two devices talk with each other directly and then cut out the WD middle man. That does not seem to be what WD decided to do though.

A proper test to see if this is the issue would be to create a port forwarding rule for the mycloud on your router (so that initiating connections can happen from outside and reliably reach the mycloud) for SSH (port 22), then try SFTP directly to the mycloud, and see what your speed is, vs using the mobile app.

I am discreetly suggesting that your bottleneck is the WD server farm that is brokering your connections.