Upgrading from 2 x 1TB to 2 x 2TB in my Mybook Studio 2... will it work?


I’ve bought a couple of WD Green 2TB drives to attempt an upgrade (as the advertising touts) to make my 2TB Studio Edition into a 4TB one… but it doesn’t seem to show me the full 4TB…  Does anyone have experience with this upgrade process?


Just an update.

I’m running OSX 10.6.6 and WD Drive Manager 2.25.

I did an experiment and changed the drive to ‘RAID 0 : FAT32’ from ‘RAID 0 : HFS+’ and the software suddenly shows the drive as being ~3.7TB instead of the 2.2TB it would show me beforehand, changing back to ‘RAID 0 : HFS+’ still shows the drive as being ~3.7TB so it looks like it was just a bug in the WD Drive Manager software preventing me from seeing the full RAID 0 array of 2TB + 2TB drives.

Hope this helps anyone experiencing the same difficulties.



I’m trying to achieve the same thing: upgrading to 2x2TB drives in a my book studio enclosure (no LCD panel). Which ‘software’ are you referring to where you changed to RAID 0 : FAT32’ from ‘RAID 0 : HFS+’ and back again? Was it Disk Utility, or WD Drive Manager?

If disk Utility, where did you find the RAID 0 : FAT32 option? I can only find FAT32/HFS etc (without RAID), or RAID in a completely separate tab.

If WD Drive Manager, how do you get it to launch? I’m having trouble starting the drive manager at all.


I figured you mean Drive Manager. I had my drive connected via eSata and nothing was working, RAID Manager would launch but would not recognise the drive. Plugged in via USB and was able to make the changes you wrote about, however my 2x2TB drive is still showing up as 2.2TB total (not ~4TB). Hmmm, back to the drawing board.

OSX 10.6.6

Ok. I have it working now: a 4TB My Studio II 92x2TB HDs). HEre are a few things I did and learned along the way.

I’m running RAID Manager 2.25 on OSX 10.6.6.

I have three My Book Studio II enclosures; one 1TB model (2x500GB HDs) bought a couple years ago, and two 2TB models (2x1TB HDs) bought more recently. I think this is important to note — that the products as sold to me were 1TB model and 2TB models.

Firstly, make sure you have your drive plugged in via USB as my eSata connections were not working with Drive Manager or RAID Manager. Once running via USB, the drive showed up in RAID Manager. with eSata, the drive could only be seen in Disk Utility and only at a maximum of 2.2TB.

I’ve been trying to hack my 1TB into a 4TB, and I was having no luck at all. It appears that the 1TB enclosure would not recognise my newly installed 2x2TB drives as 4TB, no matter what I did. It would recognise at a 2.2TB array (in Disk Utility), but I couldn’t get it any higher.

Next I tried using one of my 2TB enclosures which is where I had some luck, replacing 2x1TB HDs with 2x2TB HDs. I’m not sure how you can get around this if you don’t have access to a 2TB enclosure. Once I could see the drive in RAID Manager, I recofigured from RAID0 HFS+ to RAID0 FAT32, which then showed the drive as ~3.7TB. Disk Utility also recognised the drive as a 4TB drive. I reconfigured back to RAID0 HFS+ which still showed the larger capacity.

That’s it. I now have a 4TB My Book Studio II*

* I should mention that it’s the old 2TB model running at 4TB now. The 2x1TB disks I removed from the 2TB model are happily running in my old 1TB model. In a nutshell, this is what happened:

  • Original 2TB model is now a 4TB drive

  • Original 1TB model is now my old 2TB drive 

  • I have 2x500GB drives to use elsewhere.

Bonus advice:

The HDs were seated quite tight inside the enclosures. When doing the above — swapping out drives from the My Book Studio II enclosures a lot — I broke two of the plastic ring pulls. To make things *A LOT* easier, I sprayed some WD40 onto a paper towel and moistened the sides of the HDs. Not very much, just enough that I could see a thin film on the sides of the drives. The drives slid in and out of the enclosures MUCH easier. Don’t know if there’ll be any long-term side effects, but it made the whole job less frustrating.

What operating system are you all using?

The 4tb drives need Windows 7 to work properly with.

Hi guys.

Someone I know is trying to do the same but he can’t get Drive Manager to identify the 4TB, even with your tips.

Since I was registered with WD, I told him I would try to ask here.

There is one thing, which is not in this thread, and may be the missing link since, it’s also the cause of the ‘same size drives limitation’ on these units, which is the firmware.

So, I would like to ask you guys the following:

Thanks and regards.

(Also sent you a PM about this to get the most attention, sorry).

All of your information is a little bit skewed, gentlemen.  There is no issue with the firmware or the drives, it’s an issue with which partitioning scheme you are using to partition and format the raid drives.  Check out our KB Article below.


Thanks for your answer Mr. bill_s but with all due respect, a WD support member told me recently, by mail, that these units would not accept drives with larger capacity than the ones included and that there was no firmware update to overcome this limitation (i can forward you the mail if you want).

Also, this thread is in the ‘External Drives for Mac’ section, so I assumed we were talking about drives formatted with GUID or APM (Apple Partition Map), but my friend actually didn’t format the new drives, so they may be in MBR. If they are, maybe I may have found the solution, thanks to your help.

I’ll be sure to thank you if it works out.


and yet, unfortunately, after the guy i’m trying to help formatted and partitioned the drive again (even if it was in GUID already) and tried the tips above, in WD Drive Manager, he still gets 2TB maximum…

Let me know if someone has any more tips…