Upgraded from Win 7 32 bit to Win 7 64 bit and now can't install WD Utilities

I was running Win 7 32 bit and had no issue installing and running WD Utilities for my 3 My Book external drives. I just upgraded to Win 7 64 bit and now I can’t even install the software. I could really use some help as I obviously don’t want my drives spinning 24/7.


WD Drive Utilities installs and works fine on my Windows 7 Home 64-Bit Service Pack 1

Direct Download Link: https://downloads.wdc.com/wdapp/WDDriveUtilitiesSetup_for_web_2.0.0.76.zip

This is the version I’m trying to install but when I click the exe file, and then run, it does nothing. I’m running Win 7 Pro 64 bit with SP 1. I’ve tried a couple of the suggestions on the community boards but nothing has worked so far.

What type of HDD are you trying to use the WD Drive Utilities software with ?

I just tested 2 HDD’s i have … a 4TB WD Elements USB Portable (picture example below)
and 3TB WD Elements Desktop and both were recognized in the software.

Note: Both of these drives are USB or DAS (Direct Access Storage)

I have 3 My Books 2 8tb and one 4tb. I solved the problem thanks!

Now I’m having an issue downloading the drivers. I downloaded the dashboard as you suggested on another post but there is no option for updating the drivers. Do you have any suggestions? I suppose I could start a new post but thought I would ask you now first.

Hi Joey,

I did solve the issue with the utilities software, but the old problem is back. My 3 My Book external drives keep waking up from sleep at random. I still had them set to enter sleep mode after 45 min, but they kept waking up on their own, so I tried setting the sleep time at 30 min. instead and they STILL keep waking up on their own. I’ve uninstalled and reinstalled the software multiple times in hopes of fixing this but no luck. Still seeking a solution to this problem.