Unusual defect related to .m2ts files

If I play these video files the vision stutters and the sound disappears after a short period of time. If I stop playing the video and then start again a message appears asking if I wish to “resume” playing or to “restart” 

Resume plays the video perfectly while restart continues to play with the defects mentioned above.

My system is wired i.e. not wirless

Can anyone help?

Check if you have the latest firmware update installed. Have you tried playing the same file from a USB memory/hard drive connected to the WDTV.


Sorry didn’t see you update many thanks.

Yes I have the latest update and also tried playing a video from an external drive unfortunately with the same results

*.m2ts is supported but it may be a bad encode,dvr/dvb recording … etc

Use MKVToolnix to Remux the file (takes a couple of minutes with no quality loss)


I always use this program as the 1st way to fix a file.

The new file will be a *.mkv  … give it a try, as ive had pretty good success with it