Unknown Device after every restart

Hello Guys,

I bought MY Passport “USB 3.0 + USB 2.0” Model “WDBACY500ABL” and I formated it once I got it to install Snow Leopard on it and it worked just fine on Mac OS X but when I tried to install Windows either 7 or Vista, tells me every time it’s unknown device, I know it’s related to USB Mass Storage Device Controller but I’ve tried so many solutions here but I couldn’t fix it till now.

The Problem is when I plug the device in, it works fine but once I restart the computer, I don’t get my drivers or anything and the driver is “Unknown Device” and can’t find it it safety remove aera or My computer so, it’s like the OS forgot the software driver for this device so, please could you help me fixing this problem or I have to return it to the retailer in my country to check the cable?.

I tried to connect My HD to my friend’s PC and it worked well.Do you think I have a power supply problem or what do you think?.

Please Help!.:wink:

Have you figured it out ?

I have the exact same problem…

Same problem here as well … and apparently no solution offered by WD so far. 

This might be related to power, have you checked the power settings in your USB ports? Sometimes, Windows limits how much power you can use from the USB port, as you stated, it worked in your friend’s computer.

To check your power settings, follow the steps below:

  1. Open the Device Manager. To access Device Manager right click My Computer, left click Manage and then Device Manager.

  2. Click on the + sign next to Universal Serial Bus Controllers to expand the selection .

  3. Right-click on USB ROOT HUB and select Properties on any listing that displays.

  4. Click on Power Management.

  5. Uncheck the box that says “Allow the computer to turn off this device to save power”.

  6. Repeat steps 3-5 on all others USB ROOT HUB listed under the Universal Serial Bus Controllers section.

  7. Restart your computer.