Unable to register new drives

I have just attempted to register 4 x 6TB WD Red drives that I bought earlier this month, but received the following message,

Thank you for registering your product(s), 0 product(s) were registered out of 4. The following asset(s) failed to register: because it’s either an OEM product or the warranty has been voided. For further assistance, please contact the WD support team …

I successfully managed to register 4 x 3TB WD Red drives that I bought 2-3 years ago from the same well-established retailer / system builder (Novatech in the UK).
What’s likely to be going on?

I did try to contact the support team but when I tried to create a support case I got the error message “An error was encountered during knowledge base search”. When I tried to create a simpler email through WD’s web page, it insisted I provide a product number or serial number but gave me no field to complete for that purpose … :frowning:

Bill R

Hi,

Try this link instead to email WD Support.