Unable to read WD My Passport HDD on windows after connecting to NAS

      I had connected my WD Passport 1TB HDD to my new WD My Cloud device to access files from my connected HDD,. After I ejected the hdd from the NAS and connected to a win8 laptop, i am unable to see read the contents of the drive and explorer crashes. Now I am not sure if the data on the drive is safe or what happned to them. Need help to solve this issue.


   i connected this to 3 other laptops and still the same problwm. But when i connect the hdd back to my nas device it i am able to see the content. So i am not sure what the problem is here.


  I have logged into the laptop as a user with Admin rights, will this not be enough? Should i try this option with the administrator login itself?

Also when i move the data from my wd drive to NAS i am not sure if the copy happned, how do i find it out? Is there a way to see if the copy process is still on?


   Also when i connect my hdd to the laptop, i can see the drive showing as “local disk e” but when i access it the explorer hangs and ultimately crashes.

I also tried to connect with Administrator login still the same issue.


  I have attached the device properties and the device manager scren shots if it can help analyse the issue better.


I would suggest the following… Because it looks as though your WD My Passport has become corrupt… If you can replicate the same conditions on similar laptops or a PC then it looks as though it could be the device itself. Not necessary corrupt beyond repair.

Shut down WD My Cloud then pull the power cable and wait a minute for the power to drain and then reconnect WD My Passport to your WD My Cloud and then plug the power cord back into WD My Cloud and wait for this to come back on then go to to This PC (Assuming that you have upgraded to Windows 8.1)…

  1. WB + E (to open This PC)

  2. Network then WDMYCLOUD (Assuming you left this as default)

  3. Click on WDMYCLOUD then the USB attached device

  4. Backup everything from your Attached WD My Passport to your PC (making sure that your copy the WD files needed to restore your WD My Passport)

Erase your WD My Passport (Once you have backup up your WD My Passport) and then safely remove the USB device from your WD My Cloud and then reconnect this to your PC and see if this is recongised once attached. It should be working again now. But unfortunately there is not the boring task of putting everything back onto the drive again. Which I appreciate if you have a lot of files and folders on there it will be a laborious task.

Hope this helps keep me posted.

Sure I thought of this as the worst case option. But I am really unhappy with this kind of corruption for no reason or mistake of mine. All my personal videos and photos are in this hdd, I will be really mad if I lost any of these. Ideally WD has to give a solution for this issue. I am not sure how to. Intact support in europe , not sure if I get some one who speaks english as we’ll. I have raised a support ticket with WD support, but still no one bothers to respond to me, this is bad customer service in any means. I am a really unhappy man today…

Finally I was able to solve the issue of hdd not being recognized on PC. I connected to Ubuntu and I was able to read the contents of the drive. Somehow the hdd drive format shows NTSC, but file table got changed. Hence had to backup the drive and reformat the hdd to make it usable. I guess one thing to remember is not to leave the hdd on when firm ware updates are done on the nas. I see that is the cause of this issue…