Unable to reach NAS shares while HTTP access works

I have a curious problem with my NAS. I’m able to reach it over HTTP, but I can no longer access the shares.

Symptoms
(I did tests on a Windows laptop over Ethernet and a Mac laptop over WiFi)

My NAS was connected to a router and running at 192.168.1.14. I was able to reach the web UI on both the Windows and Mac, but when entering \\ 192.168.1.14 in Windows (without the space; that’s a forum markup issue) I got the “Windows cannot access \ \192.168.1.14” error. My Mac is also unable to connect to the share. The error I get in Finder is The folder can’t be found.

The NAS was detectable in the Windows setup wizard, but not in the Mac setup wizard. When running the setup on Windows, I got an error that was identical to this screenshot I found on the internet.

I ran nmap on my Mac to do a port scan and I got this result:

Starting Nmap 6.47 ( http://nmap.org ) at 2015-11-08 19:35 CET
Nmap scan report for 192.168.1.14
Host is up (0.050s latency).
Not shown: 990 closed ports
PORT      STATE SERVICE
80/tcp    open  http
110/tcp   open  pop3
111/tcp   open  rpcbind
143/tcp   open  imap
443/tcp   open  https
548/tcp   open  afp
993/tcp   open  imaps
995/tcp   open  pop3s
9000/tcp  open  cslistener
49152/tcp open  unknown

Nmap done: 1 IP address (1 host up) scanned in 2.06 seconds

Why am I unable to access my shares? I’m running the latest firmware.

Hi,

Have you tried power cycling the device to see if this helps? Also you can try to do a reset, here is a link that might help you with the reset process:

I’ve turned it off and on before, but that didn’t change the situation. I looked into the possibility to reset the NAS without data loss, but even the ‘Quick Factory Restore’ option erases data. The help article you posted unfortunately doesn’t apply to the My Book Live.

Also, this is very weird: I can access the public share via a shortcut that was created by the WD My Book Live Setup process, but I can’t navigate to it in Finder. Screenshot: http://i.imgur.com/QANewiP.png This seems a little inconsistent, doesn’t it?