Unable to properly setup WD2GO

I have setup MBL on my home laptops, and have no issues. However, when I setup a second user on WD2GO, that user is having so many issues. First we got stuck where many other users were stuck. We would get her logged on, then she would click on the shares and the browser would time out. We fooled around with a couple of options, one being the Windows XP Configuration, another being the FTP. We also went into her firewall and opened a port 443. All of a sudden she was able to log on. I changed the settings back to automatic and she can still log on now.

However, when she tries to open the files that are in the shared folder, it asks for her username and password. When we type that in, it keeps on asking, as if the password was incorrect.

I have checked this many times. We have the correct password. I can log on with her information at home, withouth the WD2GO, and her username and password works fine, I can access the files from the dashboard without a problem.

I have checked my router and it is UPNP enabled, but my dashboard still says relay connection established, and suggests that I enable UPNP in my router.

Please do not reply with any information about updating Java, or telling me I am entering the wrong password. I have seen these two responses all over this forum and I have checked these things. Also, I have checked to ensure that my firmware is updated, so please do not reply with that either.

I believe that either the problem lies somewhere in my settings, or in the firewall router settings of my secondary user.

But I do not know… Please reply, I would like to hear from WD Staff, because this appears to be a very common problem with very few solutions.


FTP has NOTHING to do with WD 2go.

Are the documents she’s opening Microsoft Office documents?

Hi there. It doesn’t matter what file type, one of them was Microsoft Office. Quickbooks also will not open for her. I believe all files in the folder would have the same password… so it seems to be something to do with permissions. But I have given her full permission to that folder. So I do not understand why it will not accept her password.

It appears I know absolutely NOTHING about how to use this hard drive. I am very sad and frustrated. Between my time and hers this setup has cost me $480… and after 8 solid hours I have no idea why passwords work when they do and why they are refused half of the time… I am just hoping that some random thing I do will make this work!

It might help to know… I got it running optimally in my own house. I had Quickbooks open on two different computers, with 2 different user names. I was able to enter data in one, save, and immediately the data was apparent on the other computer… Just like I was hoping. However, for some reason I cannot get my employee to access the exact same data from her place.

Also, I took the share and changed it to public. It still asks her for the password upon opening files inside the share, even though now it should be accessible to all users.

WD 2go uses WebDAV for networking.  It may be that Quickbooks does not support WedDAV file shares without additional configuration.  Office 2010+ doesn’t, either.

If it’s a permission issue on the files or folders, then you can try using the SAME MBL user for both YOUR connection as well as the WD 2go connection.  If you do try that, then you nay need to move the files OFF the MBL, make the user changes to the share, and then move them back so the file-level permissions get reset.

Thank you so much for your reply. I had my employee log in to WD2GO with my user name. She was able to go into Quickbooks. However, we still cannot get her into the Excel spreadsheet, so it probably is related to the WebDave… I saw a message in a forum for how to manually change that to Microsoft. ‘something’… When I tried to co into cmd and enter the map location with a forward slash delete, it says it cannot find that. Is this something I should try in more depth? By switching this will I bypass the problem with Microsoft Office? If so, do you have any suggestions to make that process easier for me? Also, we are still having problems getting Marlena in the folder under her own user information… It is odd that she can use my login but not her own to access that share. I also tried logging in as her and had problems with what I think might be the permissions. I am going to use the reset button on the back to reset all passwords, delete her account and re-add her… perhaps I just did something wrong the first time. I will let you know how that goes, in the meantime, any more advice you have is greatly appreciated! Thanks again!

DunRite wrote:

…I saw a message in a forum for how to manually change that to Microsoft. ‘something’… When I tried to co into cmd and enter the map location with a forward slash delete, it says it cannot find that. Is this something I should try in more depth? 

I’m guessing you’re talking about this:


That’s only relevent for LOCAL connections.

WD 2go REQUIRES WebDAV access, so you won’t be able to change it from “Web Client Network” to “Microsoft Windows Network.”