Unable to Play Selected Videos - Youtube Downloaded MP4 Videos

Dear Users,

I have recently purchased WD Live Hub 1 TB and enjoying watching the movies, however I’m unable to play the MP4 videos that are downloadable from youtube website using a registered program downloader. I would be greatful if anyone can help me in this regards

Vibs

EDITING: I have found solution by using VLC Player remuxing feature… See the posts below for the solution

Download MediaInfo and post the full Text output for one of the MP4 files that won’t play.

It could be that the video codec is unsupported.

BTW, this is the Live/Live Plus forum; a moderator might move it to the Live Hub forum later. :wink:



General
CompleteName : D:\videos\Adele - Rolling In The Deep.mp4
Format : MPEG-4
Format_Profile : Base Media / Version 2
CodecID : mp42
FileSize/String : 63.9 MiB
Duration/String : 3mn 53s
OverallBitRate/String : 2 294 Kbps
Encoded_Date : UTC 2010-11-29 23:30:12
Tagged_Date : UTC 2010-11-29 23:30:12
gsst : 0
gstd : 233840
gssd : BADC205E2HH1304852289539013
gshh : v7.lscache7.c.youtube.com
Video
ID/String : 1
Format : AVC
Format/Info : Advanced Video Codec
Format_Profile : High@L4.0
Format_Settings_CABAC/String : Yes
Format_Settings_RefFrames/String : 1 frame
Format_Settings_GOP : M=1, N=50
CodecID : avc1
CodecID/Info : Advanced Video Coding
Duration/String : 3mn 53s
BitRate_Mode/String : Variable
BitRate/String : 2 165 Kbps
BitRate_Maximum/String : 14.0 Mbps
Width/String : 1 920 pixels
Height/String : 1 080 pixels
DisplayAspectRatio/String : 16:9
FrameRate_Mode/String : Constant
FrameRate/String : 25.000 fps
ColorSpace : YUV
ChromaSubsampling : 4:2:0
BitDepth/String : 8 bits
ScanType/String : Progressive
Bits-(Pixel*Frame) : 0.042
StreamSize/String : 60.3 MiB (94%)
Tagged_Date : UTC 2010-11-29 23:30:13
Audio
ID/String : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format_Profile : LC
CodecID : 40
Duration/String : 3mn 53s
BitRate_Mode/String : Variable
BitRate/String : 124 Kbps
BitRate_Maximum/String : 150 Kbps
Channel(s)/String : 2 channels
ChannelPositions : Front: L R
SamplingRate/String : 44.1 KHz
Compression_Mode/String : Lossy
StreamSize/String : 3.46 MiB (5%)
Title : (C) 2007 Google Inc. v08.13.2007.
Encoded_Date : UTC 2010-11-29 23:30:13
Tagged_Date : UTC 2010-11-29 23:30:13

The mp42 encoding (MPEG-4 version 2) is not supported by WD (mp4 is the container and mp42 is the encoding).  You will have to remux the files to something that the WD supports. 

thanks

I have found out the way to remux the video using vlc player … as shown the snapshots below

By using this Method you can play MP42 videos in WD Player WITHOUT ANY LOSS OF QUALITY . By using this method one can also convert any non WD compatible video in WD Compatible format. 

01.jpg

02.jpg

  03.jpg

04.jpg

  05.jpg

06.jpg

07.jpg

08.jpg

09.jpg

  10.jpg

11.jpg

12.jpg

13.jpg

Gosh that is some process just to get a youtube video.

Out of interest I used youtube Downloader HD and the video played OK on my WDTV Hub even with mp42.

some MP42 videos play fine but some doesn’t … this method is the genelized way … not just specific only for the youtube stuff… I have many mp42 videos that weren’t playing fine on WD … however now days most of videos are playing fine… I’m also using youtube downloader HD :slight_smile: