"Unable to play selected file" in regards to Upnp


I purchased a WDTV live brand new only a few weeks ago and when it works it works great. But having used it for several weeks i’m starting to noticed a lot of bugs have been coming out.

My biggest problem is the “unable to play selected file” error message when I try and play a MKV h.264 off a NAS drive (seagate drive plugged into an ASUS RT-n56U). What confuses me the most is that the coverage is very hit or miss. The WDTV will work perfectly for a period of time but once that error message comes up, it doesn’t want to go away.

The WDTV live will play an Identical file on a thumb drive, and I have had instances where a file will miraculously play after ten plus attempts. It seems as though it’s becomming less cooperative over time.

 I specifically remember on one occasion removing the power to reset the device, which fixed my issue at the time but lately hasn’t been working anymore. The only thing I can do now is reset my router which forces the device to rescan the NAS and takes 30+ minutes to repopulate all items.  I  have used other devices to play files on the NAS drive while the WDTV is giving the messages so I’m nearly certain that the problem isn’t nas side.

any suggestions?

Just a quick update after some experimentation.

My home setup consists of four devices for testing purposes.

  1. WIndows 7 desktop PC

  2. Windows 7 laptop PC

  3. Asus Router w/ NAS

  4. WDTV Live

I’m able to play music videos and photos from the router to the desktop and laptop

I’m able to play music, and view photos from the router to the WDTV live, but UNABLE to play ANY video formats.

I’m able to play music, videos and photos from the Windows desktop to the WDTV live

It appears that the only breakdown i’m having is video from the NAS router to the WDTV live.


Now having reset my router, I attempted to play the first MKV h264 that populated the list and recieved the “unable to play the selected media” message. After that I tried playing an AVI file and it worked. Once the AVI file played I went back to the origial MKV and it too played, as well as all other MKVs that continue to populate the list.

I’m just getting more and more confused.

Be sure to update the firmware to the latest version.


A little bit of progress:

before this latest firmware everything would work great until I added a file to my nas drive. Once the file was added everything gave the error message “unable to play the selected file, please see the user manual”

Over the last week the latest firmware seems to have fixed the problem, but not completely.

At first I was having issues of the smp not seeing the upnp server, resetting to factor default and rebooting the router would solve that. Adding files seemed to not cause that error message anymore.

Today I had a similar problem. I made to file transfers to the drive. One consisting of 8 files and one consisting of a single file. The single file finished first and the 8 files finishes second. My smp would play any one of the 8 files, but not the single file transfered, or any other existing file on the drive.

On a side note, I fould a setting in my router called “DLNA media server forced rescan?” unchecking it doesn’t cause the smp to recompile everytime the router is reset.


PS my router is an asus rt-n56u with a seagate 2tb drive

I have exaclty the same problem as you …

No problem when reading files by USB, 

UPNP reading from Windows 7 / WMP worked at the beginning (I did read mkv 1080p videos), 

then I added files into WMP, 

then I got the error “Unable to play selected files” on ALL THE 720/1080p FILES of the share. Only the old MPEG are still ok.

This is outrageous.

does anyone know a working alternative for wdtv live ?

By the way of course I have the latest update.

And I tried with another UPNP client (an IPad) and I can read the videos without any problem.

So this is a WDTV LIVE issue, I already mentioned it like a year ago, and IT WAS NEVER EVEN REPLIED.

DO NOT expect me to advise the WDTV to anyone ! (which I did until I tried the crappy network connectivity)