Unable to play audio through HDMI

Hopefully someone else has come across this issue at some point in the past.

I have a WD Live TV Plus, which I use for streaming videos from my PC through a Network Share. Yesterday, when I booted it up, the background had changed to a pinkish-purple, and I couldn’t get sound to play through my TV. It is hooked up to the TV via an HDMI cable. I didn’t change anything in the Settings, and it seemingly happened out of the blue. I tried using a different HDMI cable, but no luck. Also, not sure if this is related, but it also refuses to let me change the resolution to 1080p 60HZ. It warns me first that my TV doesn’t support this (but it does, it’s a 42 inch Sanyo, 1080p 60HZ, DL42840). Then, after I select “OK” for “Are you sure you want to change the resolution?”, it promptly does not change the resolution. Auto settings select a horrible resolution.

I’d appreciate any insight into this issue, as as it stands now, my WD Live is now a $130 paperweight.

To better address the questions on the right panel:

  • my firmware is 1.06.16, which I believe is the most recent

  • sometimes, I get a message saying that DVI input requires an audio cable additionally (I am using an HDMI cable)

  • I attempted to rollback my firmware to solve the problem; it failed to resolve the problem.

  • resetting to factory defaults did not resolve the issue.

  • not sure what it means by “other devices”, other WD networking products? I recently purchased a WD Live box, and it works with HDMI cables just fine, like this one used to.

  • power cycling does not resolve the issue.

Please let me know if this is sufficient information, and thanks


It sounds to be that your WDTV Live Plus is defective.  Have you tried using it with component instead of HDMI? You receive the same results? You may also try in another TV by HDMI.