Unable to pass "Enter network credentials" to set up a network drive on one PC Hi,


I have a big puzzle that I need some assistance, suggestion, or clues.

In just one PC (out of three that I have tried so far), I cannot connect to a Western Digital My Cloud NAS drive. When I open File Explorer under My PC, I can see the drive in ‘Network’. I click on Map network drive, enter the correct IP address, and click on Browse. In Browse For Folder window, I try to expand the drive to select the folder, and I get the Windows Security-Enter network credentials screen. This is where I am stuck.

Every valid user and password set up in My Cloud gets rejected with “The user name or password is incorrect”. The same user names and passwords work perfectly in other PC’s. Is there something I need to do on the PC to set it right and accept a valid user name and password?

Thanks in advance for your help,


Have you entered the network credentials for the network you are using? Are you on 2.4 GHz or 5 GHz band network? What is the Username and Password?

I am on ethernet connection and not through WiFi.
Hope you are not a phishing scammer - why would I reveal actual ‘user name’ and ‘password’ in the forum?

I think that was just poor wording on Cat0W’s part… . . he is a frequent and helpful poster on this forum.

I have seen issues with Windows Credentials manager with regard to NAS boxes. Apparently, Win10 does not like multiple users for a single ip address or device name.

Try going into Windows Credential manager and scrubbing references to the NAS and the IP address the NAS sits on. After that, you will have to enter user/PW once when you log in for the first time. . .and it should work after that.

You don’t enter it here but, on your device, when it is asked for!!!

@cat0w - Earlier was a joke. Apology for the quip.

@NAS_user and @cat0w - I followed NAS_user’s advise and cleared Windows Credential and scrubbed references to the NAS. Restarted the PC and then tried to map the network drive again, but it still did not work.

This time, in the browse for folder window, I got further and can see the folder directory. When I pick on a folder to map, the same Windows Security popped up asking me to sign on to the NAS, and I still got “The user name or password is incorrect” error.

What am I still missing?

Does the error message say anything else besides “The user name or password is incorrect”?

One troubleshooting step if you haven’t done so already. Access the My Cloud Dashboard and change the permission on the Share to Public. That should remove the need to enter in a username and password to access the Share. Then see if you can map the Share.

@Bennor - that’s the only message and I have tried everything.

I searched on the internet, found several suggestions, and I tried them all, but none worked. PC Reset but keep settings and files did not work.

My final solution - I reset the PC and NOT keep any settings and files, and that finally did the trick.

The PC is now back in working condition and I can access the NAS drive.