Unable to map MyCloud

#1

I recently bought MyCloud, and it seemed that the device has been working smoothly, until I attempted to map the device on my Laptop (Widnows 10).

The device is connected to the LAN network, and it appears under storage devices in the Network folder, but when I start mapping the device, it does not show there.

It worked fine when I set up the Desktop App, but when I tried the Setup software, it does not detect the device, and this message appears: “make sure you have properly connected the provided ethernet and power cables and the led is a steady blue then click to rescan”.

Note that mapping worked fine on a Windows 7 PC, while my Laptop is a brand new Windows 10 Acer.

Please help!

#2

Does mapping the network shares manually in windows 10 work?

#3

It should. I attached a screenshot, and you can see that it does not show MyCloud there.

#4

IS the MyCloud in the same workgroup as your PC?

#5

Here is what shows on mine. The Mapped drive shows under, This PC. I have Windows 10 with all the latest updates.

Click on, tap or activate image to enlarge it.

#6

This is what shows on mine.

#7

Same problem here :frowning: Any solution?

#8

If you are using Windows 10 ensure SMB 1.0 is enabled.

Other past discussions with suggestions if using Windows 10.

#9

After troubleshooting this for days, I learned that the windows update 1709 blocked the sharing (explains why it worked and then it didn’t all of a sudden). I was able to map a network drive via the instructions in the user manual here and everything is now back in working order. Note: the My Cloud ultra device doesn’t show up in the computers-- I simply had to put in the IP address in the file system explorer address bar, then when the files showed up i just right clicked on the share and chose map network drive. DAYS of research and failed tries-- 30 second resolution. Akl because of the good advice to read the user manual above. Here’s the link that saved me: https://support.wdc.com/knowledgebase/answer.aspx?ID=26161&lang=en#subject2