Unable to map/mount WDMyCloud at bootup

During bootup, reconnect fails. i have to manually go to WD Quick View and map the Public folder after very bootup. also, it asks me to enter my credentials during mapping. is there a way to automate the whole thing so that when the machine boots up, it mounts the drive automatically? I am running Win 7 OS on my desktop. Hope someone can help me. Thanks.


Well, on the link, which one is the one we need, because I do the exact same thing, and when I do a PC reboot it says “could not connect to the network drive” or something similar, And I have to remap again, and write password…etcetc.

edit.: yeah, I guess we need some sort of delay on start to mount the drive, and registry tweak for passwords maybe, any suggestions?

On Windows it will give you that message on boot up because it tries to connect to the mapped folder before it actually connects to your network.

However, you should not have to remap the drive to access it.  Once your PC is completely booted, you should be able to click on “Computer” and the mapped folder should be visible.  If it has a “X” on it, but shows the drive free space/size you should be able to open it and the “X” will go away once you access the drive.

Tinwarble: u r terrific. thanks for the link. i spent 15 min with the WD Tech Support and the guy was clueless… The tutorial was useful - i entered WDMyCloud\login for the credentials and it did the magic!!!

Registry file (disable the error on startup)

Windows Registry Editor Version 5.00


Put hidecmd.vbs into W7 Startup Folder

(“c:\Users_USERNAME_\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup\hidecmd.vbs” )


Set oShell = CreateObject ("Wscript.Shell") 
Dim strArgs
strArgs = "cmd /c c:\wherever\youput\yourbatfile\wd.bat"
oShell.Run strArgs, 0, false

 wd.bat ( F Can be whatever you want to map your drive, like O, Z)

net use F: \\WDMYCLOUD /USER:username password

username, password, change them to fit your setup.

With this, W7 will mount your network drive each restart, and you wont see the ■■■■■ error message nor command line window.