Unable to login to registered user

Unable to login as a registered user after cancelling a copy.

Plug in My Cloud Personal NAS to my Mac via ethernet.
Open Finder > Computer/Network/WDMyCloud.
Click Connect As… and enter Registered User information.
Browse data. Drag copy contents of several folders to another external drive successfully.
Started copying 1TB of contents (didn’t know it was this large),
Cancelled what I thought was successfully—copy progress bar window closed. Waited a few seconds and disconnected the drive from the computer.
Tried powering it down but it never shut off after several minutes.
Unplugged power after a few minutes.
Plugged drive into another computer to resume copying data.
Repeated steps above to login, entered credentials, pressed Connect button.
Window appears saying:

““There was a problem connecting to the server “WDMyCloud”>
Check the server name or IP address, and then try again. If you continue to have problems, contact your system administrator.””

Tried going back to original computer but issue persists.
Tried different passwords but get a different behavior—so I know the registration information is good and the drive does too it’s just unable to connect to the registered user.

I can still Connect As… Guest and copy information but there is a ton of data still on the registered user side.

Any help would be appreciated.

Anyone know some Connect to Server or Terminal workaround? Once again, my credentials are CORRECT.

What do you mean by “plugging drive into computer”?

This is a network device. You connect device into an ethernet port on your router. From there, any PC/MAC can connect to it without changing wiring. You should be able to have BOTH PC’s / MACS read/write data to the drive simultaneously.

I plug in an Ethernet cable into the drive and the other end to a USB-C dongle. It’s directly “networked” to the computer. it’s a faster connection when transferring data.

There were also previous issues with it being seen on the network so just trying to get all the data off it and move on.

ok. . .I see what you are doing.

Not exactly the “normal” way to hook up the system - – → but it should work.

This sounds like a network configuration issue. Unfortunately, I don’t know MAC’s so I can’t be much help. Have you tried hooking it up to the network “normally” (i.e. direct to the router); and connecting to the device in the standard way?

It is likely the IP address for the My Cloud may have changed when you powered off the unit and connected it using Ethernet directly to another computer’s Ethernet port.

WD Support has a knowledge base article that may, or may not, be relevant to your issue:

How to Access My Cloud When Connected Directly to a Computer

What color is the front LED of the My Cloud? Assuming it’s a single bay/single drive My Cloud unit since you haven’t indicated the exact My Cloud model. It is possible the My Cloud is doing a disk check or reindexing the drive contents which can result in the My Cloud being inaccessible for a significant period of time while that check or index is in process.

UPDATE: It’s working and copying files as we speak.

Hold down reset button for 40 seconds as soon as you plug in to power.
Then log in as Guest.

Bennor, you are my hero! After plugging in the device and holding the reset button at the same time for 40 seconds I was able to login as a Guest and see all the users and data from before. Truth be told I should have looked up the manual online but I panicked after not being able to access the registered user.

Interestingly, it also won’t recognize the previous user name and password as if it doesn’t exist, but admin/password it tries to log in and gives me the same issue and error from first post, “…contact administrator…”

Thanks again Bennor!

For the record:
Drive is WD 3TB My Cloud Personal Cloud NAS Storage P/N:WDBCTL0030HWT

Some steps previously taken:
Plugged into our router it wasn’t able to be seen on our network—I am willing to try again as I have found other solutions from forum users during my recent research.

I WAS able to access the registered user directly connected to my Mac through ethernet. After cancelling a copy, unplugging and replugging it in to a different Mac (and any subsequent Mac), it now only lets me access the Guest.

I left it overnight and it didn’t “fix itself”. I was thinking if I could do a disk check or repair manually that would help as there was some corrupted data or index file after cancelling the copy. But that didn’t fix it. Only the 40 second reset from the manual.

. . . you can’t access the previous user name and password because you did a 40 second reset.

This reset is specifically intended to allow you to “start over” with all the user accounts and network settings of the NAS; but still retain all the previous data.

Check the link for the details on what the reset does.