Unable to install windows 7: cannot create partition

 I put together my own pc with a 1Tb caviar blue. When I go to install windows 7 64 bit, I get up to the point where it asks me to select a hard drive to install windows to. My hard drive shows up, but it does not allow me to choose the hard drive, saying, “windows cannot be installed to this disk. this computer’s hardware may not support booting”. I cannot create a partition on it, as it gives me another error.“Failed to create a new partition on the selected unused space.[Error: 0x80070017”

. I have tried many things, and looked at other similar issues, but none was Identical to what I had. 

I hooked up the hard drive to my old computer, which ran vista, and attempted to partition it from there, but it could not be initilized or partitioned. Whenever I tried to initilize it, It would tell mere there was an I/O error. 

I have also tried to use  Shift+F10 and use diskpart to manualy create a disk, but it says there is a  Data error

In the bios, the drive shows up perfectly fine, and I don’t know what to do. Any help would be greatly appreciated.

It seems that the drive is bad

redundacy check error normaly happens when you have non recoverable sectors

Try changing your SATA cable first. Then try running the WD Data Life Guard to see if there is any problem