Unable to install Transmission

I really hoping some can help me here. I had transmission installed previously on my PR4100 and last night I saw that there was an update available. I tried to update the app but it showed initializing but then said failed to install app.

My mistake was uninstalling the app and then attempting to reinstall it again. When I tired again to install I received the same message.

I tried doing some research and attempted to restore system defaults as well as going in through ssh and deleting anything related to transmission in nas_prog.

Please help!!!

@conshok26 Thank you for reporting the issue with the PR4100 Transmission 3rd party app.
In the mean time, you can download the app and install it manually.

http://downloads.wdc.com/apps/MyCloudPR4100/Transmission/MyCloudPR4100_Transmission_1.07.bin

from console snap install transmission

Please could you link to the previous Transmission for My Cloud installers, 1.05 rather than 1.07? If not all of them, then just for the EX2100 and the EX2. Thanks.

[edit: I can find the tar.gz on the WD Support site, but not the bin installer.]

Hi! After upgrading to v1.07 on my PR2100 I can not connect to Transmission Web UI from outside my local network. I get this error:

421: Misdirected RequestTransmission received your request, but the hostname was unrecognized.To fix this, choose one of the following options:Enable password authentication, then any hostname is allowed.Add the hostname you want to use to the whitelist in settings.If you’re editing settings.json, see the ‘rpc-host-whitelist’ and ‘rpc-host-whitelist-enabled’ entries.This requirement has been added to help prevent DNS Rebinding attacks.

I tried entering my external hostname to the whitelist in settings.json over SSH, but it doesn’t help. Is there any way to downgrade to previous version? I didn’t have this problem before.

image

Coloque * em rpc-host-whitelist
Apenas isso.

Attention acesse por INTERNET EXPLORER

I took your link and change the path, and found the 1.06

http://downloads.wdc.com/apps/MyCloudPR4100/Transmission/MyCloudPR4100_Transmission_1.07.bin

changed to

http://downloads.wdc.com/apps/MyCloudPR2100/Transmission/MyCloudPR2100_Transmission_1.06.bin

From there you can donwload the 1.06 :smiley:

So I had to uninstall the 1.07, reboot, and then install this one. Refresh the browser cache, and now I have access to my good old transmission ^^