Unable to initialize My Book

I run Windows 7 64-Bit.

I have a My Book 4TB externall HDD. I was using it for my media streaming, and had taken my DVD / BD library and put it on the drive and used Plex Media Server to some Roku boxes at the TV’s in the house. Great set up, worked perfectly.

A month or so down the road, my SSD died. It was cheap, so no surprise.

I put the My Book on another computer, installed Plex but was having drive ownership issues. I went through and changed ownership of the drive and files and it worked perfectly. The secondary machine also runs Windows 7 64-Bit.

A week or so later, I had the original PC up and running with a new SSD. Took the drive off the secondary PC and back on my main. Reinstalled Plex, changed ownership and it worked. Only problem was after a few minutes of inactivity it would lock the drive, forcing me to use the WD Drive Unlocker to unlock the drive. Also, all the WD software on my PC would not recognize the fact there was a WD drive attached. I could not use any WD Smartware utilities for the drive. My only solution was whenever I wanted to watch something on Plex, I’d have to go up to the computer room, use the drive unlocker, then start up plex on the Roku.

I spent weeks trying to troubleshoot the problem. I figured it was some kind of permission error that prevented the WD software from recognizing the drive, but at least I could use it.

I finally decided to copy all the data from the 4TB drive to another external drive, with the plan to reformat the drive and copy everything back.

As I’m sure is obvious by now, I could reformat the drive, and set it to GPT to see all 4TB in one partition, but when I try to initialize the partition I get the “media is write protrected” error.

I can’t use any WD Smartware software to correct because it can’t “see” the drive, it tells me I have no WD drive connected.

I’m hoping there’s a solution, I’m about to smash this drive and mail it piece by piece back to WD with a letter telling them how I feel about their products with each piece.


I recommend you contact support directly for assistance with this issue.

General Phone Support

You can also try another USB cable to see if it helps.

WD Support RMA’d the drive and have replaced it. Thanks!