Unable to copy certain file names to MyBook Live

I have a new MyBook Live 2tb and have just started to backup some files to it. The problem I have is that the file name seems to not be accepted on the MyBook Live.  A file called MOD-2010-10-28-15:43-1194.MPG will not copy however a file called MOD_20101028_15431194.MPG will write just fine. I did not expect this to fail. Can someone please tell me if there are restrictions on file names that can be used? Windows and Linux can open these files and copy them with no problem.

broadstairs wrote:

A file called MOD-2010-10-28-15:43-1194.MPG will not copy…Windows and Linux can open these files and copy them with no problem.

Surprising.  In Windows, colons ( : ) are illegal characters in file names.  They are permitted in Linux, though.

So, what are you using to copy, and what error do you get?

I have it mounted in Linux and trty to copy from my old hard drive which was in my Buffalo Linkstation to the MyBook Live and it tells me I cannot write the file. I did expect the underlying system on this to be Linux and therefore accept these file names. Does not matter what I use to copy these files it is the same error each time just cannot write. AFAIK : is allowed in Mac file names as well. It is the : (colon) as when I remove it the file copies OK. Problem is that I have 1400+ of these files!

From what I’m reading online, Samba does not often support colon in file names.


What puzzled me is that my Buffalo Linkstation was quite happy to allow these file names to be stored on it, uploaded from my Linux system. It also ran Linux/Samba I believe. Now the same Linux system cannot write to the MBL with these characters which leads me to believe it is the version of samba installed in MBL.

Having said all this it is not a show stopper, I’ve renamed all 1400+ files to remove the colons and now they are backed up just fine. It was only one set of video files which were renamed like this because they included the time stamp as part of the name. Rnaming was easy with KRename which does it automatically using a template, so all the same data is there but without the colons!

Granted in a mixed environment one should be careful but I am in the process of removing Windows altogether from my environment. I’ll just stear clear of colons in future.

Yeah, or a different Samba.cfg option on one or the other…