Unable to connect to OneDrive

Hello there,

I’ve spent 6 hours yesterday trying to link the WD Home to my OneDrive account - without any luck. All other services (Dropbox, Google Drive, Box, Facebook) sync without any issues, only the OneDrive service is giving me hell.

When I click on configure Social and Cloud import service the OneDrive button is greyed out. Enabling it immediately displays a blank page stating federation.mycloud.com took too long to respond; sometimes it’s just a blank page (see images below).

Read a lot around here about Google Drive similar sync issues and tried all the suggested ways to resolve the problem: logged out of OneDrive, disabled the Social and Cloud import service, re-enabled and logged in again, used different browsers and OS (Windows, MacOS an the WD Home iOS app), rebooted WD Home. I’ll appreciate some ideas here because my main cloud storage is OneDrive. Thank you.


@dimitar_kostov The following is from the Knowledge Base. Have you already tried this?

Thanks for the reply. Yes, I did. As you can see all my cloud accounts are connected but OneDrive.

@dimitar_kostov what country are you located in? Can you private message me your email addressed being used by MyCloud.com?

Hi @SBrown,

Thanks for your help. I am not able to send you a private message, maybe bacause there is a limitation or something for new users in the community: “you can’t send a message to that user”. Is there some other way I can send you the data requested?

P.S. I’m located in Bulgaria, Europe.

I’m having this exact same unit. It keeps saying that I have the wrong password but I’m 100% certain that this is the correct password.