Unable to connect to mycloud over gigabit ethernet

I have connected my wd mycloud to my router via gigabit ethernet port on the router using dhcp. I am using cat6 cables. My macbook pro is connected to my router via gigabit ethernet to thunderbolt adapter. I am unable to access cloud device or dashboard via ethernet. Please be noted that internet and everything is working fine on ethernet. I can see mycloud device on router device lists. If I unplug the ethernet and connect via WiFi mycloud connects and I am able to access device and dashboard.

Can anyone help why it isnt accessible via ethernet?

I would suspect that you are on two different Networks due to either
a) different subnets
b) different ip networks
c) static IPs of either your My Cloud or your MacBook pro.
d) reserved IP from the router.
e) different DNS, one pointed to router and your My Cloud is pointed to open DNS just because it is faster.

Yes I’m speaking gibberish

so while you are able to connect via WiFi check the assigned IP of the My Cloud, write down the ip address, subnet and the DNS its that it chooses. I assume that since you see your MyCloud on your router list that you know what you are doing.

Then check your MacBook ip while on Wifi, it too will have the IP, the subnet and a DNS server address.

Lastly go back to ethernet connection where you are having all the problems but this time check your IP when you are on ethernet. Perhaps you are on a totally different network that does give you access to the internet but doesn’t give you access locally. All your IPs should match closely on the first 3 sets of numbers with only the last number varying from 10 to 240.

and lastly… If you cannot browse for the My Cloud, try using the IP address that you wrote down

  1. in finder go connect to server
  2. type in the server address like
    smb://192.168.yyy.xxx
    or
    afp://192.168.yyy.xxx

where yyy is usually 0

I have seen on my new router to ip addresses of 10.0.0.10 so change the 192.168 to follow suit.

This should map your my cloud no matter what.

Good luck…

Okay so first of all I am really thankful to you for your suggestions. I tried the suggestions but no luck so I am going to explain my network so kindly bear with me. I think after you get the idea of my network you can better guide me.

I have a fiberlink internet connection. My ISP has provided me with their own router. Fiberlink wire connects to ISP’s GPON router. This ISP router has no WIFI and only a gigabit ethernet port on the back.

Now I have a TP-Link Archer D5 router with gigabit ethernet ports. It has 4 ports among which 1 can be used as WAN port. I connected a patch cable from my ISP’s router’s ethernet port to Archer D5 WAN port. Now to connect my Archer D5 router to internet I went to Archer D5 and in Dialup connection I entered username and password provided by the ISP and successfully connected to the Internet. I have configured my archer D5 router to have an IP address 192.168.2.1 and Subnet Mask 255.255.255.0. I have enabled DHCP on this router along with 2.4GHZ(SSID:Mark I) and 5GHZ Wifi(SSID:Mark II).

Now I have another TP-Link router (TL-MR3420) which I basically use to extend my wifi coverage to the other end of my house. This is used rarely. From its settings I have configured TL-MR3420 IP address to be 192.168.3.1. Its SSID is Mark III. It also has DHCP enabled. This doesn’t have much to do with my problem so ignore it but I just wrote so that you know.

My WD myCloud device is set to DHCP and Is connected to Archer D5 via patch cable. I also have my macbook connected to Archer D5. Macbook is also set to obtain IP from DHCP. So to summarize the 4 ethernet ports of Archer D5 router:
1- LAN1 (WAN) => ISP’s ethernet connected to this port
2- LAN2 => TL-MR3420 router connected to this port.
3- LAN3 => WD my cloud connected to this port.
4- LAN4 => Macbook Pro connected to this port.

While connected to SSID Mark II of my Archer D5 from my Macbook Pro, I can access WD myCloud (J-A-R-V-I-S) in browser through IP address 192.168.2.105. Below is the snapshot of client list of Archer D5.

Now If I disable WIFI and connect my Macbook Pro via ethernet I can access the Internet perfectly but unable to connect to WD Mycloud. Below is the snapshot of client list when connected via ethernet.
2

While my macbook connected via ethernet and unable to connect to WD mycloud, if I open 192.168.2.105 from my iPhone it successfully connects to WD mycloud.

I hope you get the idea of my problem. I look forward to your response.

Please HELP

Due to your multiple DHCP on, you have basically isolated everyone on a separate network.

  1. First step turn off all DHCP except for one preferably your ISP modem/router DHCP.
  2. when connecting multiple routers do not use the Wan port for input. Simply connect from one output port to one of the 4 LAN ports just as you would with a switch. This would keep everyone in the same network.
  3. If you don’t have enough LAN ports, I would suggest getting a cheap switch to fan out from your ISP router so one port goes to your Wifi router with DHCP off. DHCP comes from your Router.

You can get some nice cheap TP link switches from Amazon for $20+ for 8 ports. Use the switches for additional gigabit ports and not a router. You can add a wifi router to your switch but as mention above, turn off DHCP and make sure the router is in bridge mode, or just connect a network cable to one of the lan ports and not the WAN port.

Good luck…

Shouldn’t it also be isolated on wifi then?

  1. ISP modem has no DHCP, no wifi nothing. It just provides an ethernet port to connect to a router to get internet access. So my main router is Archer D5 and it has DHCP enabled.
  2. On my Archer D5 router I have to use WAN port as input so that I have internet connection else no internet. I have connected my second router (TL-MR3420) to my Archer D5 router. I actually dont want these networks to be same. I want to isolate the network of TL-MR3420 because it is used rarely and only used by guests so I have kept it separately so that guests dont come to my home network. That’s why different wifi SSID and different subnet.
  3. I dont need an extra LAN port at the moment so maybe later.

If you think 2 networks are creating the issue that is not the case. I disconnected the second network of TL-MR3420 ( unplugged cable from main router) but it is the same.

@usmanwalana,

Telling me that multiple DHCP doesn’t have any effect on your problems and telling me that you cannot access your My Cloud is like telling me that your brakes has nothing to do with your gas pedal.

There are two basic component to a router that makes it a router and that is the DHCP and DNS. These two determines the IP or the address of the device and redirects anybody asking for that address to that device. The DNS IP within your local network usually points back to your router which is usually 192.168.0.1 and your router determines whether the ip that you are requesting is inside or outside your local network. So if your My Cloud is connected to a second router that has its own DHCP through the WAN port of that router, when you request access to the My Cloud, you get routed to the second router IP but no further.

When your device like a My Cloud boots up, it will send out a signal asking for an IP and if you have multiple DHCP, everyone will send out an IP and at this point, I have no idea which IP your My Cloud will take. According to your description, It seems that it would take the IP from your Wifi router thus you would have access to the My Cloud via Wifi. If you connect your gigabit ethernet directly to your Wifi router, you probably would be able to access the My Cloud just as you would via Wifi.

Having multiple DHCP on a network confuses all the routers to where your individual devices are. It may appear to work mostly but as you have found out, switching to ethernet hides your My Cloud from you because the path to your My Cloud is not available to your connection point.

Disconnecting various routers from the mixed up Network, thus removing the multiple DHCP, may seem to have no effect and that is because every device you have is already confused and requires a re-boot starting with the initial router followed by each device to re-acquire a new IP from one DHCP source.

Ok fine having multiple routers with DHCP can work if you connect from one of the LAN port of a router to the WAN port of another router, those becomes two independent network and the two DHCP won’t affect each other but in order to access the my cloud on the second network you need to use the assigned IP from the second network and the subnet must be the same (maybe). You won’t be able to browse for your My Cloud because your DNS won’t have any knowledge of where your My Cloud is. I do know that a static IP on your My Cloud (outside the DHCP range) will definitely allow you to access the My Cloud across two different networks (same subnet).

If you wish to have wifi, you can set up your main Wifi router as your main router. Turn off DHCP on your ISP router (ISP = internet Service Provider/Main router) and if you can there might be an option to turn on Bridge mode, meaning that your ISP router will become just an internet bridge connector to your Wifi router.

Optionally you could do what I did is to have the Wifi Router operate as a bridge router with the IPS router running DHCP and all the Wifi Router does is provide Wifi connection (DHCP off).

I hope all this info helps you figure it all out and again good luck.