Unable to change password when attempting Mac Shares

Hi all,

just unboxed my WDTV today, but I’m wondering if it’s DOA. I have enabled Mac sharing, the HDTV connects to the network without any problems, but when trying to connect my network drive, the user says “guest” and the password displays “**********” filled in the box. There’s also a locked padlock displayed next to it. I can easily change the username for “guest”, enter a new one and submit. I can then edit the password, but when hitting submit, the password box still shows the same long string of asterisks, and not the shorter password I just typed in. I have tried factory reset, and clearing logins of both Mac and PC shares, but that same string of asterisks will not go away.

I am trying to access a HDD connected to the USB port of a Time Capsule. Other devices can see the HDD without any issues, and I have file sharing enabled. The HDTV can also see the TC OK, but when trying to log in to it, I have the password problem. I have tried different usernames, but the password (whatever it happens to be) remains and will not change.

Is my unit faulty? I’m beginning to think so. The manual doesn’t refer to any existing passwords being stored in the system anywhere. I have raised a case, not sure how long that will take.

Any help greatly appreciated.

Cheers,

Adam

Accessing a hard drive connected to a Time Capsule device is not as straight-forward due to the networking protocols used by the media player. NFS or SMB need to be manually configured on the computer system, and I am not aware if you are able to extend the configuration to the Time Capsule:

WD TV Live Streaming or WD TV Media Player cannot access media content shared by a Mac running OSX 10.9, 10.8, or 10.7

Thanks Trancer.

I have progressed a little further after following the link… I had already set the external drive to file sharing, but when going into preferences, I was able to activate SMB sharing. That got me around the password issue in Mac Shares, and I could access the TC on a slightly deeper level than previously.

But now the WDTV says that there’s no media on the drive, when there is.

Looks like its time to forget about this device and get a Mac Mini capable of handling HD. With the drive networked on the TC, my existing Mini recognises it and connects well. XBMC (Kodi) works beautifully, but the Mini comes to a halt with HD, it’s too old and slow.

If anyone thinks they can get past my “no media found” error, I’d appreciate it, since I can also use the WDTV to drive this TV for black and white nights. Those RCA outs are useful.

Cheers,

Adam