Unable to access WD My Cloud Mirr

I have a NAS drive (WD My Cloud Mirror) that was originally set up and mapped to an older laptop of mine. I have not used this NAS drive in a while. I recently dusted off the drive and tried to connect it to my new laptop when I ran into difficulties.

The NAS drive is directly connected via ethernet cable to my laptop.

Laptop is running Windows 10 Enterprise 1809.

Laptop’s IP address on the ethernet card is set to

I was able to retrieve the IP address of the WD NAS drive by using the arp command and it’s set to

I have forgotten the name of the root share folder on the NAS drive.

The problem:

I am unable to map the NAS drive to my laptop. When I try to click on Network in Windows Explorer OR use the Map Network Drive option, I get a “Network Discovery is turned off” error.

To enable Network Discovery, I turned on / enabled all of the below

  1. In Advanced Network Sharing, network discovery is turned on for Private, Public, Domain and All Networks

  2. DNS Client, Function Discovery Resource Publication, SSDP Discovery, and UPnP Device Host sevices are running

  3. Network Discovery is checked in Windows Defender

  4. Ran the following command as administrator netsh advfirewall firewall set rule group=”Network Discovery” new enable=Yes

  5. SMBv1 is checked

In spite of this I get the "Network Discovery is turned off’ error.

I was able to ping in the command prompt and get a response.

I was also able to access the login console on the WD by typing However, since I had forgotten the password, I did the 40-second reset. The device did not return to a solid-blue light state after reset. It has been flashing a blue and orange light and I can hear disk read/write activity continuously since the reset.

Now, I can’t ping it or access the login console on The device also doesn’t come up when arp -a is typed in the command prompt.

Any suggestions on how to fix the error OR another way to access the NAS drive would be highly appreciated. I have critical data that I cannot afford to lose.



Hello GSwdmcm,

I would suggest you to contact WD support to get assistance in this concern.

Refer the link provided below for contact information.