Unable to access shares as non-admin user & WebUI information not displayed

In the Web UI my device is not showing anything under the Device Profile section for the name, description, and serial number which is visible in the following URL -  http://imgur.com/IeX7O75

This was visible previously however since upgrading the firmware to the latest (which resolved the much media covered ‘heartbleed’ issue). This should read the name that I set which is showing up when I browse on the network however via the wd2go panel is showing up as the default WDMyCloud name. 

The much more serious and detrimental problem with the device is that I am unable to access shares as the non-admin initial user. For example on my partners laptop I am unable to connect to shares (non-public that is) via the account I have setup for her. Thinking that this could just be an issue with her laptop I tried connecting to a share that only she has permissions granted to on my laptop and attempting to login with her details to no success.

Both laptops are running Windows 8.1 x64 connected to the same wireless access point.

Just to confirm to remove the domain part of the username on windows you prepend a ‘’ at the start of the username? This is what I have been doing for the initial user and is working fine.

I have contacted support on Friday via email about this issue providing them the log which can be genrated via the control panel however I am yet to recieve a response. 

I have tried rebooting the device to no avail and am unsure of how to progress further short or doing a rebuild which would take a considerable amount of time since it took 6+ hours copying over 0.5TB of data to the device. 

It looks like my problem was resolved by performing a system only restore which wasn’t too much of a problem as I didn’t have a complex setup with regards to shares.