Unable to access My Book Essential

Hey everyone,

Seems like a lot of people are posting about this issue, but I figured I’d give it a whirl and see if maybe there’s something that was missed.

I bought the My Book Essential about 14 months ago. I had a bunch fmusic stored on the drive and about 3 months ago, for some reason I couldn’t access the hard drive. I would plug it in and the computer would detect it, but I couldn’t double click on it and open it up. All it would do is just freeze and sometimes (maybe 1 out of 3) it would ask me to format the drive. 

However, if I were to just type in the path of some folder and bypass the intial HD access it would work.

For example:

My Computer>H: Drive = freeze.

Typing in “My Computer/H: Drive/Music/Jimi Hendrix” = acess folder no problem.

Now, fast forward to 2 days ago and everything continued to work just find. I could access it the same way as mentioned above. One you could “by pass” double clicking on just the hard drive, it worked find.

Then yesterday, I tried to go onto it and it wouldn’t let me do anything. Again, I plugged it in and the computer detected it just fine. And then when I would try to double click on it, the address bar would start to fill, get to about 97% and then just sit there until it became unresponsive and asked me to close the window.

On occasion, it would ask me to format the disk and if i click yes, again it just would fill up in the address bar and then freeze one it got to 97%. I don’t know if it’s trying to format it or if it’s just trying to read it and can’t do it.

Finally, I was able to recover all of my saved stuff from it. I spot checked everything and it seems like all of the saved data has no problem with it.

Any help would be great.



It sounds like something may have got corrupt. Since you have recovered all of your stuff I would suggest running WD DLG and see what that shows about the drive health. Find your drive at WD and look in downloads. If the drive tests OK I would just reformat it and see if that fixes it.


Kyle - I’m having a similar problem. How did you end up recovering your files?

What OS are you using and does the drive show in Disk Management?