Unable to access device (1003)

Hi all, new to the community, hope someone can help.

I have a My Cloud 2 terabyte.

The issue that I am having is when I try to access a specific file, I get a  message, “Unable to access device.  (1003)”.  Has anyone seen this before and if so what can I do about it.   Thanks in advance. 

You have not given a lot of information to work with.


I take it you have your My Cloud all set up. You have on your dashboard your users, shares, cloud access and settings all set up.


What type of device are you using, desktop, laptop, phone etc.? They all have the proper apps?


The more info the better. Images of what you see help too.

Hello everybody


I have the same error message at the moment that I want to download a file using the WD interface for Android’s handy (Samsung S4)


 To be most specific I have a WD My Cloud 3TB, actually the only user available is me. In my mobile phone (Samsung S4) I installed the application provided by WD. I can get access to my cloud using this app without any problem; also I can open all the files as well. The error that I have is at the moment that I want to download (not open) a file (no matter it is music, pictures or documents) to my handy, the app shows that is trying to download the file after some seconds display that is not possible to download and later on if I try to open again (not to download) the fail appears a window with the error message “Unable to access device (1003)”.


I really want to know what is going on, because is very frustrating that you only can stream your information and then is not possible to download.

1 Like

This is a generic error with access (network).

How are you connecting?  Over wireless, 3g/4G? Have you tried the same operations with other devices/PC?


I have the same issue : unable to acces to my document (except pictures) through W2go Android Appli on my Samsung S4 mobilephone. But all shares are visible on the W2go interface on the mobile…

For exemple, I am unable to open excelsheet or to download it on the mobilephone. I have the same error message “unable to connect… (1003)”

I suffer this issue when I am connected via 4G or wireless (of my house or an external one).

Have a nice day !

Geenrally speaking this is an Adnroid error indicating connection difficulty or errors. Check your network. Netflix users with Androids use to have this problem and it is network related.

one way to check on your lan (home network) is to disconnect everything from your router except the PC and do a repeatable steps to download, stream whatever you want to do. Then slowly add devices.

Then switch to 3g/4g and repeat the above  steps.

Make sure nothing in the ourter is blocking streaming.

Keep records of everything.

1 Like

Hi Jamalaya,

THanks for your answer. It is very strange because I am able to download a file from my WDMyCloud to my S4 on a local new folder. From this local folder, I am able to open and modify the document.

After that I am able to upload it from my mobilephone to my WDMyCloud. I have to change the name of the file and I am able to delete the previous version.

This way to proceed is quite fastidious…

But if I try to open it directly from wd2go or to download it (without specific folder) it doesn’t work.

So I am not convinced that is due to a network (wireless or 4G) issue.

Good luck !


Without troubleshooting would be defficult to nail down specially a v. rare error like that. It i sintersting that other users (not mycloud) saw this error, rare too.

So you download to your mobile phone, open it, edit. but when writing it back you have to delete the original file, and  change its name to save it?

Is this the same procedure form a PC ?

Hello all,

I have the same issue, when trying to download a file from the android app “WD my cloud”.

I have a WD my cloud 4tb

Some comments

  • Im able to open the file but not download it, download fails and message Unable to access device (1003)

  • The firmware of the WD my cloud device is the latest available version, same for the android app (using a galaxy note 3)

  • It happens when connected through wifi and 4g/3g

  • After the download fails, then the file is unaccessible when trying to open (Unable to access device (1003))

  • The only user available is me

Can someone help with this matter?

Thanks in advance

Hello Karoshka

As well, as you describe Ihave the same problem. And actually I don´t think that is a connectivity problem.

That must be a WD software problem.

I hope someone can give us a right answer

Hi Jamalaya,

I have to download to my mobile phone BUT I have to specify an other folder than the one used by default by WD2go.

From this specific folder, I can open, edit, modify (and save) the file on the mobile phone.

After that I have to upload the file to WDMyCloud. WD2go save it on WDMyCloud with a new name “initial name-1” and it does not overwrite the previous version of the file.

Therefore if I don’t want to have several version of the file, I have to delete the previous one from MyCloud. It is my personal choice to change the name in order to always have “initial name”.

I don’t know if it is the same procedure from a PC but I tried this morning with my android tabled (ACER INCONIA TAB) and I did not suffer the same issue: I was able to open directly the file from WDMyCloud through WD2go apps, to modify it and the new version was directly saved on WDMyCloud.

I am convinced now that this is not linked to my wifi connexion.

I hope that these complementary explanations will be helpful…

Hi Soda24.

Yeah I wasn’t clear and people assued I am blaming the actual network connections (my bad). What I meant is that (and I am not certain) that it could be the connection from the phone itself. It could also be a buggy app.

This is  a very rare error and I have only read about it where people with Android phones connecting to Netflix and having the same error number. Netflix response, if I recall correctly, that it was a connection error from the phone, not their network.

The best thing is check this error with Android forums, a lot of people there hack Androids, they can check it or even look it up in the source code, and this is where I have seen the error in the source code, and unfortunately I cannot remember now where.

Hi everybody,


I’m facing the same issue as described by Kartoshka.


I have a WD My Book Live 3 TB and a Samsung S4 with the app WD My Cloud. I’m using WIFI connection and the internet is OK. Everything is set up and working properly except some JPG files in a specific folder which I’m unable to access (error 1003). FYI the files are not corrupted and may be opened in my PC.


Let’s call the folder with those JPG files as B. Folder B is a subfolder of the folder A. Folder C is also a subfolder of the folder A with JPG files. The funny thing is that I can easily open the files of the folder C but I can’t open the files of the folder A.


So I decided to move the folder B out of the folder A. Suddenly I managed to open all the files. But when I tried to download them the error 1003 came again. Afterwards the files were unable to access due to the same error!!


Jamalaya, I hope this info is useful and sufficient for you to solve this issue.


Looking forward to your helpful reply.