Twonky server - can't play anything on my toshiba TV

Hi everyone,

I need your help with my case. I have a Toshiba 32SL415U. I’m using a WD my cloud 3TB. When I first configured it, everything was working fine. Then, I upgraded to the last firmware(WDMyCloud v04.01.01-413) and then I wasn’t able to see anything on my TV. 

I performed a firmware downgrade(WDMyCloud v03.04.01-230) to see if I could go back to the way it was before but i’m presenting the same issues. I don’t remember which firmware I had before I upgraded for the first time. 

I was looking for an answer in the forum, but I didn’t see a case like this.

I would really appreciate some help on this matter.

Thank you all,

Hello there and welcome tot he WD community.

I have not tried this, lets see if any other user has tried this and can share some tips and information about this matter. I can recommend going into the twonky web interface then checking if the TV is listed there.

Here is a link that might help you out with this:

any error messages?

did you try to rebuild the twonky DB?

any other DLNA players you can test with? Windows media player …

some devices are extremly picky, my Dish hopper/joey supports DLNA but only seems to work when the stars align

in the twonky setup http/mycloudIP:9000 you can see and change the device profiles it is using, you can try others and see


It was listed the first time (when I first configured it) but now it doesn’t. 


My TV is being able to see every media player connected in my local network (My laptop, my sister’s laptop, etc…) but I’m still presenting the same issue. 

any other DLNA players that can see and ply from the mycloud?


I’ve  only tried windows media player.

media player as a source for the TV?

Or as a client for the mucloud? try this if not

Sadly, a firmware upgrade will overwrite the Twonky settings. So, if you used the Twonky UI to set the location of your media, you’ll have to do that again. I’d suggest doing a ‘rebuild database’ from the Dashboard, since a firmware upgrade also seems to change a long ‘magic number’ string in the twonkyserver.ini file. At the worst, you may have disable media streaming, to log in to the MyCloud Linux platform via SSH, and delete the entire /CacheVolume/twonkymedia directory before restarating media streaming. this will do a completely clean start of Twonky, after which you can use the Twonky UI to set the media locations.

One other possibility is that the firmware upgrade has disabled media sharing; look under ‘shares’ on the Dashboard.

Essentially, the integration of Twonky into MyCloud is very poor.