Twonky 'no playable file' for any video files

Hello everyone, I would appreciate any help with resolving this issue (I’ve been working on it for 3 days now, getting absolutely nowhere.  I’ve tried rebuilding and rescanning but that doesn’t help.):

MBL 2tb with the latest .020 firmware release

Sony BX57 (Costco version of B570 I think)

Twonky 5.1.9 that came with the MBL, but have also tried the update to 6.0.34 version (using instructions from this forum)

I can see and play all photos and all music.

I can see all the folders for video, but get ‘no playable file’ for everything in video (but I can see all the files in the folders when I look at them from my PC, and can play them on the PC when I access them from the MBL).  Twonky dashboard correctly counts that I have 61 videos.

As a test I installed Twonky for Windows 6.0.36 on my PC.  Using that I can see and play all video (the same videos that are on the MBL).  Unfortunately there is no .36 version out yet for Linux so I can’t try that on the MBL to see if that solves it. 

So, it looks like the Sony BX57 has no problem with dlna to play any video I stream from my PC using Windows Twonky server, but when I try streaming from MBL, it doesn’t recognize any video.

Did you enabled individual media serving from the MBL dashboard?

i too have the same prob… pls come out with answers… itried all formats…

Posted to the wrong thread.

In doing some quick research on this player, I see other NAS’s having issues with DLNA. In the past, I know that Sony has been fickle in what formats they support on their TVs and players. Even though they are DLNA certified, they only support a limited number of codecs.


Found this support article on Sony’s web site. Check to see if your model number is listed. DLNA support seems pretty limited on these devices:

I am having trouble accessing anything on the My Book Live since the 2.x firmware update from any IOS device. I have 4 and none of my DLNA streaming software sees the drive as accessible, yet XBOX 360 and every computer sees the device. So something changed in the firmware and affected all my apps that used to be able to stream.

Apps that no longer see the MyBookLive: Twonky Mobile and Fusion Stream. This does not work on IPAD 2, IPHONE3G, IPOD Touch 4th withIOS 4.3, IPHONE 4 with 5 beta software.

Hello Tony,

Thank you for the reply.   My Sony BX57 (from Costco) is probably like the 570 listed in the article.  But I am not sure why that would be the problem as I am able to stream the exact same video content (.avi, .mov, etc.)  from my PC to the Sony through a Windows version of Twonky (but a newer version, 6.0.36, than the one on the MBL).  Wouldn’t that suggest that the Sony is able to accept all video content, but for some reason not when it is coming from the MBL?  Or not from the Twonky version on the MBL (I tried upgrading to 6.0.34 but that didn’t help, and I just tried 6.0.37, but that didn’t load, I think because they are still working out some bugs in that release)?

Update: I uploaded an mpeg file and the Sony could see and play it!  That would tie in with what you read about the Sony only able to play specific formats, but it still leaves me baffled why the Sony can play all formats when streamed from my PC.  I am starting to think it’s the Twonky version causing the problems.  The V5 that comes with the MBL is pretty old now.  I installed 6.0.34 but that didn’t help.  But the 6.0.36 Windows version does work, so I am hoping once they sort out the bug in the Linux 6.0.37 version, that that will solve the issue.

I have the Sony Bravia KDL-40EX700 (new within the last year) (It says DLNA certified) but in looking at the list of Sony models in the link provided - the KDL-40EX700 is not listed.  It is exhibiting behvior similar to that provided in this post - folders appear - artists, genres, etc, - yet opening them reveals “no playbe file”.  The Sony KDL-40EX700 can see and play the individual song titles - in painfully slow alpabetical order - yet the list of songs is quite incomplete - and after navigating about halfway through the list - the media player function on the Sony just freezes up and appears to lose contact with the MBL.  Since I did not buy the drive for its media streaming capabilities - I will probably not spend much more time troubleshooting it - but it is disappointing to see functionality that does not work.