Trying to connect 1tb passport essential se to ps3

Hello everyone newbie here. I have a USB 1tb wd essential SE passport and I can’t get my ps3 to recognize it. Drives been updated and formatted to fat32. There is now pw set. So i’m pretty much stumped.  There is nothing wrong with the drive because it works fine on my mac and pc. When its connected to the ps3 the led light won’t even come on. I can feel the drive working so i know it has power.  I have a passport 500gb that works on the ps3 so i know the unit is not the prob. I’m wondering if the problem is that its a usb 3.0? Its 2.0 compatible. Has anyone had any luck getting one of these to work on a ps3? or any suggestions. thanks in advance

It’s probably the USB 3.0.



I hear and feel your pain.

Here’s how it went for me…

I purchased a 1TB passport.  Reformatted it to FAT32, connected it to my Macbook, transferred over my video files etc, connected it to my PS3 and it was fine… everything worked.

Took the HD to work and connected it to my work PC, instantly errors started appearing on-screen, requiring the WD Smartware software to be able to access the drive… installed WD Smartware onto the work PC.  Everything a-okay.   Take it home, plug it into the PS3 and nothing… a brief flash on-screen of a drive showing and then it disappears.

I believe the issue is to do with the WD Smartware software. 

I think the steps to resolve this would be the following:

  • Copy all content off the harddrive.

  • Re-format the device to FAT32 (to remove whatever the WD Smartware auto-installed). (Maybe even write zeros to try and avoid the whole software thing at all, but not sure if the virtual cd’s etc are on protected/hidden partitions).

  • Copy the content back to the drive.  

  • Uninstall WD Smartware from Mac and PC computers. 

  • Use the device on all platforms clicking “cancel” to the errors that show asking for WD Smartware.

I discovered that if you click “cancel” on a windows PC to the error that shows, it will then load the device anyway… Or at least it did for a colleague here at work.

The downside:

  • Annoying errors jumping up on screen whenever you connect the device to a windows PC.  

The upside:

  • No error messages on the mac.

  • Connectivity and usability on the PS3. (One of the main reasons I bought the **bleep** drive).

Now, I haven’t tested the above theory out personally… Because I don’t have enough spare space on any available machine to copy all the content on my 1TB drive over to do a reformat. 

However, if you do try the above… and it works for you… please let us all know.

Very, VERY disappointed with the WD Smartware software.  Very, VERY disappointed with WD Support who simply reply “FAT32 is not supported” or “PS3’s are not supported” (Or any combination of the two) when you contact them for support.

However, I understand their drivers.  Software that limits what you can and cannot do with a drive, such as WD Smartware, opens up opportunities to flog out other products, like the WD Media Player. 

i have a SIMILAR problem… i bought the wd passport essential se 750gb (usb3.0/2.0 compatible) for the sole purpose of backing up my dvd’s in digital for and watching them on my tv through a USB channel… since my LG tv has usb 2.0 and i’ve been using a 32gb kingston pen/flash-drive to watch them; i know it works… i need tho to format the device to fat32… i did what you said and removed the smartware software stuff (i’m very technologically minded, but my mind lapses in names)… i then backed up my files onto my pc (i didn’t get any error message, this is probably because i installed a bunch of drivers for usb3.0, including the SES drivers from the smartware folder (without installing the actual program))… i tried fat32 on my tv and it didn’t work… i have a lg bluray player that has usb(2.0) but supports ntfs & fat32 (btw i formated the drive using the windows tools)… i tried the passport on the dvd player in fat32, didn’t work… i then tried ntfs on both tv and dvd player… and it worked on my dvd player… i don’t know what WD has done to their drives… but you can’t use fat32 on this and use it on anything but a pc/mac… if you don’t want to fork out alot of money for a media drive or bluray player and such… all you need is something that supports usb2.0 and ntfs… ntfs is the superior format, but much technology doesn’t support it… its much like the conversion from 32bit to 64… its not till windows 7 was released that 64bit was the standard installed and sold with any machine…

i don’t blame WD for making a stand and moving forward (technologically)… but i do feel for those with this problem… so let me ease the blow…

here’s a link with a device that is cheap… uses usb2.0, ntfs support, and every codec you can imagine: O!Play HD2 (usb3. 2x usb2. e-sata) Video : MPEG1,MPEG2,MPEG4,VC-1,H.264 Video File Extension : TRP,MP4,MOV,XVID,AVI,ASF,WMV,MKV,RM,RMVB 720p,FLV,TS,MTS,M2TS,DAT,MPG,VOB,ISO,IFO,M1V,M2V,M4V Audio : MP3,WAV,AAC,OGG,FLAC,AIFF,Dolby Digital AC3,Dolby Digital Plus,DTS 2.0 +Digital out,Tag ID3,Dolby True Image : JPEG,BMP,PNG,GIF,TIFF!Play

or try googling ‘hd usb media player’ hope this helped

finaly i know how to use this stuft!!!

I bought this item solely to transfer content quickly off my computer to be viewed on my Ps3. At first the drive wasn’t working in a USB 3.0 port on my computer. Took me about 15 minutes before I went to my motherboard manufacturers website and saw the USB 3.0 driver. Installed that and it worked perfectly. Transfer rates were a pleasant surprise. I knew it was going to be faster than 2.0 but I was shocked by how much. It typically transfers at around 87mb/s give or take, and can read a 4gb file in under a minute! The hard drive itself is small, quiet, and expensive looking, plus the USB 3.0 cable was included. WD did a great job with this product overall. It was exactly what I needed and for only $100.

Now then, for those of you who intend to use this on your Ps3, pay attention. 2 things are required to make this bad boy work. First you’ll need some third party formatter like swissknife to reformat the drive to FAT 32. Pay no attention to people who say you have to do a local format for a partition, not true. Just format the whole drive to FAT 32. This will not effect the transfer speeds in USB 3.0 either. Secondly you will need a powered USB hub! This is the key to making the hard drive work on the Ps3. You can buy them anywhere, they are about $15 and you’ll know the difference because it will say AC adapter included on the package contents. The Ps3 USB port can’t support the power that an external HDD requires thus purchasing one of these hubs will alleviate any complications. Plug the power into the wall, the USB end coming out of the hub into the Ps3 and plug your external HDD into your hub. Done, you can know use your external HDD on the Ps3.

1 Like