Trying to backup my MBL to a router connected USB drive - no luck

I finally got myself to getting a backup for my My Book Live 2TB. I bought WD Elements 750GB, I hooked it up to my TP-link WDR3600 router via USB and…nothing. I can’t get the Create SafePoint feature to find it.
I checked the router and MBL are in the same Workgroup, I tried mapping the USB disk in my Windows 7 PC (no problem there, it works). I re-formatted the drive in NTFS but that didn’t help either.
Anything else I could give a shot? Any advice will be welcomed, thank you!

Oh and I tried to plug the USB disk to my PC and share it. When I do it, Safepoint feature sees it.

I noticed there were several other users dealing with the same thing over the years but I couldn’t find any useful advice in the other topics.

You may be able to achieve what you want with a little configuring on your router.

Background:
As I understand it (i.e., not very clearly) WD devices support1 or 2 flavors of safepoint targets - a USB-connected drive and a SMB-based share. Devices like MyCloud that have a USB port support creation of a safepoint on a USB-connected device. MyBookLive doesn’t have that capability so you are limited to the SMB solution. Windows has an SMB server function which explains why you could see your USB-connected device as a safepoint target when it is plugged into a USB port on a Windows computer.

Your router has an SMB server function but you may have to do some configuring to enable it. Take a look at http://www.tp-link.com/us/faq-253.html

My apologies for not being all that clear.
I activated the drive in router settings. I can access it from the network
locations when it is connected to the router. Router allows me to set the
drive as Media server, FTP server or Print server. I tried activating each
of them but none helped.Should I focus on experimenting with setting up
Media Server then? That is SMB, right?
Thank you very much for your help!

Media Server might be DLNA rather than SMB. Maybe you should ask TP-Link.

As far as I know the Safepoint feature is based on rsync protocol.
So MBL need to talk with a server that supports rsync. I dont’t think that your router is offering this kind of service so MBL is unable to use it for Safepoint.

Moreover to correctly handle file permission the destination disk should be unix formatted ( with ext3 or ext4 ).

Well, in the mean time I installed DDWRT on my router, set up rsync there
and formatted the drive with ext3 to run rsync manually. Which worked fine,
btw. Passwordless SSH and all.
Unfortunately it didn’t come to me to check whether Safepoint works with
those settings. But there wouldn’t be much point for me anyway because
a) I found out that Safepoint doesn’t really care what’s in exclude.txt and
always requires the target drive to have as much free space as it would be
needed to back up whole MBL no matter you want to backup just a fraction of
it.
b) I didn’t manage to achieve stable WiFi with neither DDWRT nor OpenWRT so
I had to revert to stock FW.
Bummer.

Thank you for your answer, anyway!