Trouble playing Princess and the Frog

Made ISO file from BD of Princess using ANYDVD.  Plays great on computer.  When played on WD TV LIVE it starts out OK and after a few minutes audio cuts out and goes into Fast Forward with no audio.  It’s consistent and always does in same place (part where girl’s parents are tucking her in bed, just before she meets the frog on the window (I’ve endured this too many times to try to figure it out but my 3yr old Grandson WANTS THIS MOVIE!)

Have done about 10 BluRays so far using same technique and all play OK on WD TV Live.  Feeding directly with WD passport into USB port on Live.

Any suggestions?   Thanks in advance.


Any suggestions at all?  I’d convert the movie to an M2TS file.

Disney blu-rays are a *little* tricky, because they are more than one M2TS file, so you’ll need to load in the playlist.  Here’s the exact steps (all freeware):

  1. Use BDInfo to examine the folder where you ripped the entire blu-ray – it will tell you the playlist you need (in the case of this movie there are three distinct lists, one for English, Spanish and French.  Use the lowest numbered playlist).

  2. Load the playlist into txMuxer and create a new M2TS file.  This file will then play fine from your local drive (it will not be able to be streamed because the rate is too high, but that’s a different story.  I just mention that for the benefit of those who are playing along at home).

You do this and your grandson will think you’re the greatest hero ever (which, of course, you are).

Mike,  thanks for suggestion.  Will give it a try.  If I understand you correctly, just load the one big M2TS file on the hard drive attached to WD HD LIVE? 

Curious, tho.  Plays OK on my desktop and a notebook with BluRay capabilities with no trouble.  What goes wrong on the WD HD Live?



I promise you what I said will work.  Can’t tell you why it doesn’t on the Live but I don’t play ISO files from it.


It worked!  Only problem, apparently chose incorrect playlist.  Got one with audio but storyboard roughj sketches!  This particular BD has 5 feature-length playlists:  00289  00290  00291  00292  00293.  Now in process of trying 00290 (289 was the bummer.) 

Is there quick way to see this playlist prior to the 35 minutes or so to demux?

Appreciate your help and NeVER doubted your suggestion! 



As a very general rule it’s usually the lowest numbered playlist that is the standard English one.

You can try playing just one of the files in the list (one of the M2TS files the list shows) on your computer to get an idea which version you’re going to end up with.

A fresh start this morning, Mike.  Last night tried (muxed) all five feature length playlists:  00289 00290 00291 00292 and 00363 (misquoted this one as 00293 in earlier post.)  The ALL give same characteristics in playback & learned some things.

1.  They all have 2 video tracks and 5 audio tracks.

2.  One video track is for normal picture and the other is for a black & white “storyboard” of the movie, with rough sketches.

3.  Audio tracks are 1 english 2 french 3 spanish 4 portuguese 5 english.   Track 1 has normal film’s audio track with an audio overlay of a woman explaining the scenses (guess this is for benefit of visually impaired.  Track 5 has only voices of a male narrator explaining how the movie was contstructed, focusing on voice characters.

4.  Track 1 00289 would be fine if I could KILL the female scene action narration!  But, try as I might, haven’t found a way.  Am using VLC to playback and getting track/audio options by right clicking on the playback screen.

In a nutshell, how do you turn off that audio narration track - but leave the film’s audio?

Thanks for your patience as I learn.


That’s very weird – it shouldn’t have a “narration” track.  Are you sure you’re looking at the right playlists?

Assuming you did rip the entire disc (you can check by looking at the total folder size compared to the disc) then at least three playlists should not have any narration audio.  Load up BDInfo again and do this – sort on the “length” field and make sure there aren’t some playlists that didn’t show at the top (by default BDInfo sorts on the largest SIZE, and not necessarily length, and Disney uses some tricky routines to make it difficult to identify the right playlist).  Examine ALL the playlists and compare with the length of the movie.  IIRC, the correct playlist will have exactly three M2TS files, and each of these files will only have one audio track (the HD track). 

And that’s another thing – when you load the playlist in tsMuxer it should show the single audio track as HD – either DTS-HD or True-HD (can’t remember which Disney uses).  If it doesn’t then you don’t have the entire movie ripped somehow (or don’t have the right playlist).

And one more (stupid) thing – make sure you’re ripping the right disc (from what it sounds so far, that almost sounds like an “extras” disc and not the main movie).


Just finished trying something else & was about to report findings to you & just read your latest post.

What I did:

Taking same M2TS for 00289, accidentally started Windows Media Player which played it fine but started out with story board sketches instead of finished film.  Switched video tracks while running and voila!   Correct video AND audio!

Think I ended up finding a VLC player bug rather than anything else.   Have to run errand when I finish this - will transfer the 00289 file to my WD Live HD and see how it handles the file.  Will report problem as fixed if it does.

Cross your fingers for me - will let you know what happened.   As always, appreciate your newer suggestions.


OK, Mike.  Got back in from having lunch w/my son (birthday day!)

Bottom line:  Closer to target but an inch or so still away!

Copied the M2TS for 00289 to WD Live player’s hard drive & played same.  Starts playing quicky and show the ‘storyboard’ picture rather than the normal video picture.   Audio is fine (english/no narration on top of film dialogue.)

No way (I can find) to switch Camera Angle on the WD live so stuck with storyboard. on Classic Media Player (which I had thought was MS Media Player - I was wrong) I go to navigation and find two angles as options:  PID 4413 and PID 4414.  4413 is storyboard and 4414 is normal picture.  When switching angle to 4414, everything is working fine (on my computer - not on WD Live.)

Re the mystery of narration audio:  Classic Player shows 6 audio tracks:  PID 4352 is normal audio in English.  PID 4353 is the Narration audio which also carries the normal audio for the film.  4, 5, 6 are for Fr, Sp, Port.  4357 is for a director like dialogue (no film audio) talking about personalities who did voice-over for the film.

When starting Classic Media Player, picks up correct audio (pid 4352.)   Video is pid 4113 and shows storyboard.  Switching to pid 4114 gives normal film video and all is well (and it PASSES the point of fast forward so the muxing did the trick.)

When starting WD LIVE is starts with normal audio but storyboard video.  No way (I can find) to get the WD live to switch to camera angle 2.

So in a nutshell, if my Grandson liked the storyboard all would be well.  Speaking from experience with him, he will hate it.

FWIW, was originally using VLC to play to muxed file and VLC it turns out doesn’t find but five audio tracks whereas there are six.  That’s why I couldn’t get it to go to the normal audio from the narrative audio.

Sorry to be so wordy but this stuff is complex!  If any of it makes sense to you, please share any ideas you have.  I want to conquer this problem as I have an antique DVD 300 disc changer for the Grandchildren (locked to keep them from  scratching the DVD’s and using them for frisbees.)  It needs retiring & my solution is to put all those DVD’s plus my BluRay collection (small) on the hard drive connected to WD Live. 



We need to go back to basics, because I believe something is wrong with your rip of that blu-ray.  What are you using to rip?  I’d highly recommend AnyDVD HD, as other rippers just don’t perform as well.  I’d want you to re-rip the entire blu-ray again (with AnyDVD HD it’s just one click – they have a free 30 day trial so you can at least  download it and try it).

After you do that, use BDInfo to examine that disc again, because there should only be three playlists for the whole movie (if there are more something is wrong).  And finally we’ll look at the whole thing in tsMuxer – there should only be ONE audio track (and it will be an HD track, like DTS-HD or True-HD).  There may or may not be an AC3 track but that’s not important.

We’ll get there (and then you’ll have a reliable workflow).  I’ve done literally hundreds of blu-rays without an issue (well, one, but I do believe there was something badly mastered with it).


Used AnyDVD to rip on HP w7 machine.  Per your advice, will do new clean rip from original BD tonight and tomorrow, with fresh rip and fresh mind, go through sequence again & let you know results. 

Thanks as always for assistance.


Fresh rip this AM.  Using AnyDVD (latest) and Smarlabs TSmuxer gui 1.10.6.  No change - same problem.

Played around a bit and learned something interesting:  the first file in the playlist 00100.m2ts if played directly from the rip image (never passed thru tsmuxer) plays perfectly (on Media Classic.)  That same chapter, after muxing the entire playlist. starts off the video on the angle 1 track whereas the program we want is on angle 2 track.  I’m wondering if TXmuxer may have something going astray.

Anyway, I’m temporarily out of ideas.


Mike, further my last post, please.

Learned something about tsmuxer;

If play 00100.m2ts straight from ripped stream file:   angle 0:  pid 4113  correct video (the one we want!)

                                                                                    angle 1:  pid 6912  storyboard video (we don’t want)

If play 00100.m2ts after tsmuxer processed it along:  angle 0:  pid 4113  storyboard video (wd don’t want)

                                                                                      angle 1:  pid 4114 correct video (the one we want)

If play tsmuxed playlist 00289 (first in list);                  angle 0:  pid 4113  storyboard video (we don’t want)

                                                                                     angle 1:  pid 4114 the one we want

Notice that in first example, our target track is numbered pid 4413.  In second example storyboard becomes 4113.

In third example, story board is also 4113.   Must be some way to tell tsmuxer not to do this but haven’t found it (yet!)

Any ideas?


When you load in the playlist in tsMuxer in the box where it says “Tracks” it should list all the video and audio tracks it’s going to mux.  The video track (you really only want one) that you want is most likely the first track (and most likely will use H.264 as the codec) but for sure it will have, in the “track info” a profile that is 1920:1080p resolution. 

The audio track you want (and it may have many) should be listed next (after all the video tracks) and it should have either DTS-HD or True-HD as its codec (with Lang being eng).  There will be other tracks (maybe quite a few) but that’s the only one you need.

Those are the only two tracks you need – you can safely highlight the others and press “remove” (one at a time, though).  If you then mux this to a M2TS file it really can’t play any unwanted narration or video (because there won’t be any).  While technically you shouldn’t have to do this, I do admit that I run all my stuff through Handbrake after I do any tsMuxer tailoring, so that might be picking out only the one video and audio track correctly without having to muck around with this stuff.

I’ll be around all evening, so I’ll keep checking to see if this helps any (and it’s okay if it doesn’t – we’ll get there eventually :>)

OK Mike - awards time for you!  You have earned one big, sincere, grateful ATTA-BOY!!!

It worked - first video track shown was for storyboard; second video track for feature.  TsMuxed this and it gave me about 23gb and plays fine on Media Player classic and on the BD Live.  Thank you for the education and your patience, my friend.

Two questions (not problems - I now have no problems):

1.  Out of curiousity, would like to know why BD Live ‘burped’ on chapter change.  If you ever learn, would appreciate sharing this wisdom.

2.  My real estate on attached local drive will be next ‘challenge.’  What format (e.g. MKV) do you recommend for BD’s and for regular DVD’s.  Want to keep beauty of BD resolution and DTS/Dolby sound for BD rips and basically quality of DVD’s.  My amplifier (Onkyo 807) does admirable job of upscaling regular DVD’s and comparisons to standard DVD upscaled to Blue Ray native is impressive.  Not as good, but you have to look closely to notice difference.

I like portable drive connected to BD live as opposed to sharing with computer.  Odds are will have to move before long to assisted living quarters and my real estate for gadgets will shrink.  Now have a WD 1tb se Elements which works great.  Do you have any idea as to how BD live would handle two or more Passport SE’s connected to BD live thru a powered USB hub?  Or should I consider a big USB (say 2-4tb)?    I guess this is third question but would appreciate benefit of your experience.

I want to start cleaning out my DVD changer and retire it & want to do it right the first time on capture, etc.  I have ANYDVD you recommend (somehow I got lifetime license - that company is great!)  Willing to get any other software (within reason on price) that would be useful for forseeable future.

Anyway,  Princess and the Frog is resolved.  I’ll click the ‘solved’ button & repeat my thanks:  ATTA-BOY, Mike!




Glad you got it – the good news is that only Disney (with some rare exceptions) is this tough when it comes to blu-rays.  98% of all other blu-rays have the movie wholly contained within the largest M2TS file in the STREAM folder.

Let’s see if we can address your questions:

  1. If we’re talking about the original blu-ray folder, it’s due to the weird authoring scheme Disney uses.  Part of it is more copy protection (although at this point in time it’s so well known it’s hard to know why they even bother).  Part of it is just their philosophy on handling language issues – they have multiple files which swap into the stream depending on the language (and Disney, unlike nearly all other companies, wants their movies to be truly universal, so Spanish speaking folks will see the Spanish language even on screen for titles of things).

2)  I convert all my DVDs and blu-rays to MKV.  The WD Live loves this container.  And I use Handbrake (freeware) to re-encode the M2TS files into much smaller ones, with absolutely no loss of quality (I can’t see a difference even doing A/B tests on my 9’ HD projection screen).  If you want to use Handbrake (which I highly recommend) make sure you download one of the “nightlies” instead of the current release version (which is .94) because they have overcome some issues with things that did affect blu-rays (the nightlies are a *little* difficult to find from the main Handbrake site, but if you have a problem let me know and I’ll post a link).

Typically I use the High Profile preset, and only alter it in two ways: I change it to an MKV container (the default is MP4, which WD Live doesn’t like as much) and I choose “passthrough” for either the DTS or AC3 audio tracks.  This results in a file which averages around 7GB for blu-rays, and around 1GB for DVDs (but these are averages and can vary wildly – The African Queen, for example, is 17GB, and some highly digitized animation films like The Princess and the Frog may only be 4GB or less).  If you need more compression you can raise the RF factor (this determines overall quality) from 20 (the default of the High Profile preset) to 22 (it’s like golf – the lower the number the better) and your movies will then be around 25% more compressed (and *most* folks cannot tell the difference – most folks don’t have a 9’ HD screen, either :>).  It’s worth trying the same movie both ways to see what you like but I can promise you this – the quality is superb and when I do my A/B tests about half the time folks pick the encoded film over the original blu-ray disc as the better image.

The one and only drawback is time – it takes a lot of computing power to re-encode a film, and Handbrake will use every last ounce of it you have.  On my top of the line i7 machine I can do a blu-ray in under 4 hours (and a DVD in about an hour) for a two hour film, but on slower machines you can easily run three or four times that.  You *can* queue things up (so it can do multiple movies overnight) assuming you have enough disc space for it.  I started my collection about three months ago (and ended up buying a faster machine mostly for this purpose) and now I’m up to date but it does take a certain amount of dedication to re-encode all that you have.

  1. The Live will not handle powered USB hubs – if you have a network it will handle an NAS (which is what I have) and that’s the ideal situation but perhaps that’s not feasible for you.  Otherwise buy something like the Western Digital 2GB drive (or two) and you should be set for hundreds of films.

There is nothing – and I mean nothing – like having all of your movies available in one place.  I used to have hundreds of DVDs and just finding storage for all of them was impossible, let alone trying to find a particular movie (often times my wife and I would just play whatever movie we found we liked first).  I think it’s well worth the effort but every one needs to judge for themselves.

OK Mike,

Have followed your directions and have wonderfully working BD films passed to MKV files which play fine on the WD Live - with 1080P and DTS/Dolby.  Thank you for help and guidance. 

Learned two big lessons using Handbrake:  Specifying AC3 passthrough for a DTS track results in no sound (dumb I know - took a couple of overnight misfires to figure this one out!)  Also, that default track to WD Live is first track specified on Handbrake audio track list (took another misfire on this one!)

Question:  You mentioned “Nightlies” to aquire when installing Handbrake.   Couldn’t find any such reference - a clue, please.

Thank you again for the help, Mike, & hope our dialogue has helped out someone else as technically limited as I am (was?)



Wish you had written about your audio problems – all was not lost even if you picked the wrong audio track.  Here’s how to proceed if you do this again.

First of all, let’s just get some understanding here.  If we pass through an audio track, no matter what kind, all we are doing in Handbrake is re-encoding the video.  So the only stream that is of any import to us at that stage is that video track.  We really don’t even need the audio track then.

To add (or change) the audio track later is easy.  First of all, you’ll need to strip it out of the original file, so a program like tsMuxer is used to demux the track in question (and one of the options for that is to take only the core of an HD audio track.  The Live can’t play a DTS-HD file, so it’s the core we need.  And the Live doesn’t play True-HD in an MKV container either, so the AC3 core of the True-HD is all we need there as well).

Now that you have the audio track separate, you can remux it back with the Handbrake encoded video file using a freeware tool like mkvmerge.  In this case you’d load up the Handbrake MKV file, remove the Handbrake audio (the wrong one) if need be, and add the demuxed audio track from txMuxer, and then make the file. 

The advantage to all of this is that the real time needed in encoding is all video – so if you’ve spent some hours in Handbrake getting your video right, it will only be a matter of minutes to both strip out the audio track you need AND put it back to an MKV container.  So – a little complicated, but saving many hours of time.

As to the nightlies, here’s the link:

While the warning about using them sounds ominous, most experienced Handbrake users are indeed using them with great success.  As with the major rule in life, we don’t want to fix something which isn’t broken, so if you are having no issues using Handbrake then don’t worry about it.  However, if you come to a blu-ray which doesn’t work for some reason, the first thing you should try is one of the nightlies (in particular a blu-ray encoded with VC-1 doesn’t work with the release version, and you will come across these soon if not sooner).


What is the easiest way to get soundtracks only from a DVD image, if for some reason I only have handbraked the video part?