Trouble formatting new Elements for Mac and PC

When trying to set up the Elements on my MacBook Pro, it wouldn’t erase, so I tried to format anyway for ExFAT. Got a message that the format attempt failed due to not enough space on the device. I assume that meant the WD Element. But if it referred to the Mac, either is impossible, because both have well over 50% free space. Then tried to format on my PC, and could not get anywhere because the disk management did not show the links needed to follow WD instructions for formatting - such as the little red arrow I needed to click in order to initialize the disk. Also, I searched all over WD site for the “WD Smartware Pro Free Trial.” Spent an hour searching the website - could only find a purchase option, not the free trial option. Help.

This is a rather unusual case. Your Mac should not need free space to format your hard drive unless the configuration parameters were not properly set.

Did you follow the instructions in the following link?

With regards to initialization, can you post a screenshot of how Disk Management is displaying your hard drive on Windows?

The WD SmartWare Pro trial mode can be activated from the regular version of WD SmartWare. The upper-right corner of the standard version features an “Unlock” icon which allows you to try, buy, or activate WD SmartWare Pro.

You can download the standard version from a different hard drive, and go from there.

Hello Tracer,

Here’s where I am with this at the moment:

​ For safety’s sake, I reformatted the WD drive on my PC back to
the original default NTFS format, disconnected the drive from my PC, then:

Plugged the WD drive into my MacBook Pro
Opened Disk Utility

Selected the WD drive

Was asked to erase the drive. Gave the drive a name. Selected ExFAT format.
Selected GUID Partition Map Scheme.

Clicked on Erase. Mac completed Erase

Was asked about using Time Machine. Selected Decide Later

Clicked on Partition.

At Step 9 of WD instructions, (“Partition device ‘WD Elements 25A1
Media’?”) I was not allowed to specify the size of the partition, and the
APPLY button was grayed out. Experimenting, I changed the ExFAT format to
MS-DOS (FAT). I was still not allowed to change the size, but the APPLY
button was active, but I didn’t select it. So, I stopped there to write you

What I want is to divide the WD drive to 2 partitions, each 1 gig, that I
can save the entire image of my Mac and my PC on each partition. Not sure
where to go next.

I had this same problem, eventually solved it simply by changing the ‘view’ in Disk Utility to ‘Show all devices’ instead of ‘Show only volumes’ (there’s a little ‘view’ button top left of the Disk Utility window). Then I can see the WD Elements disk, not just the volume, and can erase that no problem. Seems easy now, but it was doing my head in!

1 Like

I can’t thank you enough for posting this. I have been banging my head against the wall for over an hour trying to get my drive formatted. This was all I needed to do! Thank you!!

I am having the same problem, but I do not see the “view” button on Disk Utility. What am I missing…where could the button be? Any help would be appreciated