Transferring off DL2100 - Extremely slow!

#1

I hope people can help. I am at the end of my tether.

I had a 12TB WDDL2100. Due to the placement of my router after redecorating (hidden in wall, very swish) I can’t have my NAS hooked up. It doesn’t have WiFi.

So I invested in a MyPassport Wireless Pro to put my main data on there. The plan was for them to hook up my Wireless Pro and stream through the WiFi. To do this, I would need to transfer my data from the NAS to the Pro.

Doing this is extremely slow! Like, 200kbps slow. I have tried FTP, standard Windows transfer, and even hooked up my Pro to the NAS via USB and did a drag and drop, same thing.

Where am I going wrong? I just upgraded my router and it’s just as bad, I now have Gigabit Ethernet router.

#2

Hi Dinsdale,

You may refer below article to improve both, connectivity and performance over a wireless network using WD My Passport Wireless Pro.

#3

Thanks. I’ve optimised where possible but same issue. I’ve also tried a different approach and have ran into all sorts of problems. I don’t know why I keep buying WD products because they’re riddled with bugs.

The first approach was to use FTP to transfer to the MPWP. This worked and I was getting 25mbps transfer speed, perfect… but only for about 30 seconds and then it dropped.

The second plan was to connect the MPWP to my laptop via USB, and transfer via FTP. I had to get my laptop to recognise it which it wouldn’t do but then I realised you have to switch MPWP off for it to connect via USB. So I did this - Fine, except even accessing the drive via explorer. It takes ages to load up the drive.

Even creating a new folder; it hangs for ages. I tried this on another computer and exactly the same.

So then I decided to format the drive to NTFS as per the recommendation from WD on its knowledge base. Did this, and it took ages but it worked.

But still no change, hanging just when trying to open the thing.

I’ve done all this with latest drivers, all software from WD downloaded.

Is this just a poor product? I really need to try another brand.

#5

Ok, but because of this I am literally sat next to the router with full WiFi strength and my NAS cabled in.

And in previously replies, you’ll see a ice 25mbps transfer speed. I’ve since changed tactic and now having issues with USB.

#6

I get over 100 MB/sec transfers between my MPW and my DL2100 when MPW is connected to laptop via USB3, and I use File Explorer to do transfers.
How so?
A fully gigabit system used through out; all connected via Ethernet WIRE, no wireless used. If you cannot set up this way, you are stuck.

1 Like
#7

Thanks Mike. Other than my laptop being connected via wireless, I have the same setup.

But really, this is the second problem I need to solve. First one is why is the drive so slow at even opening up when connected via USB?

#8

Hope your laptop is connecting via 5g and not slow 2.4G.
Also. are you accessing the MPW and NAS ln the Network section and not the This PC section on win FE?

#9

Laptop is connected with 5Ghz, yes.

NAS (when it was switched on) is accessed via Network location OR as the site connected via FileZilla.

MPW, I am trying to access that via Computer. Comes up, spins, and it’s painfully slow. Even just creating a “new folder” takes ages. When I highlight said folder and press delete, Windows takes ages to discover the file before asking if I’m sure to delete, and ages again before doing it. A blank folder with no data.

This happens on both my PC and laptop pre and post format.

#10

I do not have the issues you have with folders. Contact WD Support.