Transfer rates with Wireless-N standard

Hi all,

I have connected my WD live book to a TP link 300Mbit router and access via a wireless 802.11N adapter. Unfortunately the transfer rates are never above 4,5Mbit/s. I´ve done a lot of checks within the properties already.

What is your experience with that set up. Any hints tips?


The 300Mbit wireless is inferior to wired Gigabit, so it should be expected… But not that low. Are you shure there’s no firewall or bottleneck minimizing traffic?

4.5MB/s is expected on wireless N in the 2.4GHz range.  In the 5GHz range you should be getting roughly double that in practice, so about 8 or 9MB/s.

Using N in the 2.4GHz range requires a large part of the 2.4GHz spectrum - the channel overlap is large, and if there is any inteference at all, then the rates drop quickly.  The 5GHz spectrum has more available bandwidth, but also doesn’t pass through obstacles as effectively as signals in the 2.4GHz spectrum.  So you’ll get less usable range in the 5GHz band.

If you run a wire, you can get around 20-30MB/s sustained on a gigabit ethernet network to the MBL.

Thanks for that.

Regarding the FW, I use the Windows inbuild that works fine for me. I dont see there any possible setup to ease the situation. Firewall blocks traffic but dont reduce imho.

What about using 5ghz? any experience? I´ll give it a try.

Yep, I use 5GHz Wireless N all the time.  I had to upgrade the wireless card in my laptop, which didn’t cost very much, but required some careful research into what was compatible.

This thread might be helpful to you:


I had the same problem with using Wireless N.

It has something to do with the samba config.

You have to connect to your MBL with ssh… Log in there an type the following:

vi /etc/samba/smb-global.conf

Then change the “socket options” part to “socket options = TCP_NODELAY IPTOS_LOWDELAY”

Save this and restart the MBL. Then the speed should be ok