Track order on WD My Book Live using DLNA server

I use a Cambridge Audio Magic Stream 6 with WD My Book Live using DLNA server. The track order on the player is wrong when an album has more than 9 tracks. I have filled in all tags (title, album, track, disk, etc) with MP3Tag and it looks fine.

I think I have finally figured out what the actual track order is when playing, but I cannot get it reight.

See this example (with the number representing the track-tag and name representing title-tag):

1 - Track title 1

2 - Track title 2

10 - Track title 10

11 - Track title 11

Playing order will be track 1, then track 10, track 11 and then onto track 2, etc. So it seems that ttrack is read as text and used in alpabethical order. So I thougth changing the track-tag into 01, 02, …, 10, 11. But that does not help.

Any one any idea how to solve this?

Many thanks!


Try adding a 0 to the front of the numbers like 01,02,03,04,***08,09,10

Thanks for replying, but I’ve done that, see: So I thougth changing the track-tag into 01, 02, …, 10, 11. But that does not help. in my posting.

Any other ideas?

Was this ever solved ?

I have the same problem with a Cambridge NP30 and a laptop using Foobar2000.

I too had tried putting 0s and numbers infront of the track name, without success.

I’m surprised I can’t find more on here about this problem, as I would have thought it to be a major issue !

I only have a problem on 1 or 2 albums but haven’t looked into it as it is running in Twonky & don’t remember the album.

Don’t know if it matters, but was the filename edited directly or something like mp3tag was used to change the “1” to “01”?  It could be that the DLNA used the tags to provide the order for playing the album instead of the real filename.

A followup:  I just played an album that doesn’t play sequentially via track numbers.

For me, not sure the mystery is/can be solved unless one changes the directory.  e.g.  the albums in question has various subdirectories reflecting each artist in alpha order; the track number within the artist’s folder doesn’t reflect the track sequence in the album, of course.

The only fix for me is to restructure the album directory WITHOUT the artist subfolder; or delete the album & do a rip again with EAC instead of freemp3; not sure if the problem is with freemp3 or the freedb.  Don’t thing that my eac rips had that problem but don’t know yet or if freemp3 had it in the tags.

Ripping again is not an option as there 8 boxes of CDs to go thru to find “the one”.

Back again!

Alright, I found that when ripping a CD that is a compilation of files from various artists is the culprit when the “album artist” is NOT BLANK; some of us dummies entered “various” there.

A fix it 2 fold in that using mp3tag, change the album artist from various to blank (select blank) for each song; too bad there is no mass change.  After that, in my case, move the songs from each subdirectory (the artist’s name) up 1 level to the album directory.  Then most likely delete the artist’s name directories; hopefully the artist name were in the songs tag…

It’s gonna to be a long sumer to go thru my stuff to check & correct the problem albums; then backup to my backup drive!

I have the same problem with my Stream Magic 6. The streamer and the app are both going from track 01 to track 10, 11, 12, 2, 3, 4, … And all this even though when I look at the album, the songs are showed in the right order. I checked in the metatda and the tag of the track number are right so I do not know how the database is built.

The only way I found to deal with this is using the bubbleupnp app on android. I think it uses the songs as they are showd and builds a playlist from this. So when it gets to the next song, it goes to the next song on the playlist and not the next song found in the metadata.

If anybody has a clue to correct the things in the database I’ m listening.


S. Biner