Toslink audio output problem


#1

Hi!

I’ve bought WD TV Live 3 days ago. It was updated by last firmware ( 1.02.21). It was connected to my home theatre by optical cable (Toslink). In WD TV Live Setting I’ve changed audio output to “digital”. Home theatre play audio well but TV shows message “Unknown audio signal. Please check the source” because WD TV Live sends audio stream by toslink and by HDMI but my TV (Sony 40 BX 401) don’t understand the input audio stream.

When I choose “stereo” output in WD TV Live Setting my TV plays sound well.

I suppose WD TV Live should not output audio by HDMI when Toslink is connected.


#2

You’ll get argument with that conclusion.  Many people want simultaneous output on ALL outputs (for use with Slingboxes, video senders, or whatnot.)

My TV doesn’t support surround streams (anything more than  PCM or AC-3 2.0) but it doesn’t complain about receiving it; there’s just nothing there.

See if your TV supports HDMI Audio Passthrough.   If it does, try turning it on.   


#3

My TV has no HDMI audio passthrough. Any other ideas?


#4

Welcome to the forums!

I also hook up via both HDMI (to Panasonic plasma TV) and via Optical (to ancient Pioneer AV receiver).

When an unsuitable audio is sent via HDMI, the TV doesn’t throw up an error message.  There’s usually a slight time delay when audio comes from both sources, so I usually mute the TV.  ;)

Does muting the TV disable the onscreen error message or is that persistent whilst the media is playing?  I can see how that would be an issue.

I believe the WD TV outputs from both HDMI and Optical to avoid the user having to navigate menus to enable / disable outputs.  I would find that far less convenient than pressing the Mute button on a remote.


#5

The problem is in persistence message on the TV screen and TV keep silence (because it don’t understand the input sound). And I have no idea how I can hide the onscreen message (of course I read the manual for TV).

I suppose it will be awesome to have choose in WD TV settings: stereo, digital, digital HDMI, digital Toslink.


#6

Same problem. My Samsung shows an ugly icon onscreen when you mute the TV. I do NOT want my WD Live to send audio both via Toslink AND HDMI cable!


#7

Almost EVERY TVs have the option to set “TV Speakers” to OFF. Thats what I do. My WD TV Live is connected to my TV using HDMI, and I use a TOSLINK cable for the audio from the WD TV Live that I connect to my Home Theater receiver.

No error messages, great sound quality.

I have a Samsung LN46A650 with a Sony HT Receiver without HDMIs.


#8

I am using this option now, but this forces me to use always the home theatre (not to mention having to use a separate remote control only for volume levels). Just a small option: “audio only through Toslink” would have been a better option imho.


#9

Yeah, that’s not usually software.   That’s very likely Hardware, coming right out the pins of the CPU.


#10

As has been said, almost every LCD/plasma supporting HD resolutions at 720p/1080p/1080i today comes with the ability to Internally Mute the speakers or choose between External Speakers or Internal Speakers.

The sound quality coming from flat-screen TVs is also most of the time very insufficient and degraded, so you should disable it in any case if you are using a home theater system. You must understand, the speakers aren’t meant to be used for serious setups, if you are already investing in an expensive HDTV you’ll probably want to invest in a home theater as well.