Torrent app

It is from the webgui, but I suspect it has occurred because the tracker does not know how to respond to this symbol. I do not know where to start to try and replace the | symbol in the file path. This is what I suspect the problem coming down to. I looked at many transmission forum posts and it seems this is usually the case.

I would like to have the data downloaded into one of my folders, like the transmission folder, but without using an auth code. Do you know how I could do this?

Hi Have you solved your problem? I have the exact same situation.

Thanks

Are you saying that no data at all is showing up in the transmission directory on your mycloud?
What is the current value of the download dir? Feel free to replace a few digits to make it anonymous.

No data at all and no T transmission directory in the Public folder. I tried reinstalling the apk Sevres times but nothing is happening. Any idea?

Thanks

What is the default download path you see in the webgui?
Public directory cannot be used. It goes to your private data dir, the one you see in the my cloud web interface.

Thanks for your answer. After install with the python script I cannot access the webgui of the Transmission app. Just like nothing was installed.

I’ll see what I can do to improve the installation.
I compiled v2.93 last weekend so that will be a nice upgrade as well.

Can you please share the latest v2.93 so i can try it?

Thanks

I didn’t wrap it in a MCH app yet and I need to update the default config file first. I won’t launch otherwise.
Unless you want to play with an .so ARM binary?

When dobtou expect to have it ready for MCH? I really need this feature for my MCH. Thanks

Just to make sure… do these steps once again:

  • in the MCH web, in Settings tab, select your device.
  • then in the Files tab, check that there is a Transmission directory
  • if it’s not there, uninstall and wait about a minute.
  • install the package… wait 10 seconds then open the URL you get from the script.

Then I get to see the TM web interface with this download path (at the wrench symbol)

/data/user/0/com.transmissionbt.wd/auth0|59972ee35blahblah9f58a67/transmission/completed

Then I upload the torrent file mentioned above (without modifying any paths) and it works…
Check the MCH Files tab again, the directory is there.

Thanks

Do I need to use the python script to uninstall it?

Unless you know an other way, yes.

Hi I have tried the uninstall but the message I receive is: App was never installed.
I guess that is my problem, but why I cannot install the apk? The script says that the app is installed whereas it is not. Any ideas? I run the pyton.exe as admin and folder with apk has full privileges

Thanks

Analyse steps of the script, modify it to print out responses of each request and you may find out.
Note that when you use the script to install, it will uninstall the app first, then install.
So if you uninstalled first and then use the script to install, the script may say it was not installed.

which version of python should I use?

@tinomk
I also had the same problem as you. 1. after runing install script, it tell me that the installation was successful, but opening URL is not accessible, just like no installation. 2. uninstall prompted me not to install.
I used the win10 system before. Now when I change to Linux, it is normal to install again. You can also try it.

Thank you for your efforts @Tfl

Thanks for your answer

So I should try to install the APK under Linux? Then it should work?

Yes, I’m successful. Try it.