Tk Problem with My Passport

yesterday I bought 2 My Passport units. One unit worked fine and is still working. The other unit is Is not so easy to start up. It tied into a gateway 700 with XP, pent 4. The problem is I had to reformat it. When I did that It also lost the drivers, Which I down loaded from the WD site. The unit is working very slow. It took all night to copy a min 1.5 gb of data and still it is running? I can heard the internal harddrive still working. Also the unit under backup screen it shows the equal amount of storage and back up. the other unit tells you at the top back up was successfully. This unit  does not. It seems to keep running? Plus I tried to download the update version via smartware and it would  not let me do it.Unit keeps telling me to shut down all programs even if all programs are shut dowm. Help

Try uninstalling this version of Smartware and downloading and installing the latest.

It will be good for you to test the drive for errors with Smartware or DLG