TimeMachine share _Backup gives OSError to Macs

I think I have the solution to my problem, but involved so much investigation it warranted a writeup.

My sharespace was a 2TB unit with the Span configuration for ‘RAID’.

When I first installed it I could connect my MacBook to it and it could use it as a time machine backup volume. (The machine that came up in finder was -Backup. 

I wanted it to be RAID 5, so I bought a 3rd WD Green Caviar 1TB unit and installed it, then redid the volume as a RAID 5 unit. 

on restart following the RAID 5 rebuild the timemachine volume could be seen and timemachine preferences would allow me to select it as a disk. It then got into an long wait while it was ‘making the backup disk avaiable’. It then resulted in an OS error -5 (from memory).


Here’s what I understand to be the problem. There is a volume that should have been recreated as an apple share that has not been recreated on the RAID rebuild.

There is a line in the mDNSResponder.conf file on the machine that says (some numbers and names changed for privacy):

mDNSResponder.conf:“sharespacename-Backup” _adisk._tcp local. 9 “sys=waMA=00:90:AA:55:CC:22” “dk0=adVF=0x83,adVN=WD_Backup” 

Note the last ‘option’ that I presume is sent to the mDNS daemon 


I think this stands for Appletalk daemon Volume Name 

When you go to /etc/netatalk/AppleVolumes.Default, the volume is not there:

/DataVolume/Public Public

/DataVolume/Download Download

interestingly, I recall seeing in the log at somepoint that it could not find a CNID for /DataVolumes/.timemachine

that directory is present on the machine, BUT the volume is not in appleVolumes, and that needs fixing.

I note that someone else on the forum had an issue and fixed it too by adding the volume to the appletalk volumes file. That fixed it for them.

so, I propose adding 

/DataVolume/.timemachine WD_Backup

to the applevolumes.default file. let’s see what happens.

hmm - wrong.

turns out that the passwd entry for the wd_backup user lists their home directory as /var/lib/timemachine

in there was a .AppleVolumes. This contained:

/DataVolume/.timemachine WD_Backup

So, Fail.

perhaps it will recreate this directory if I rename it to something else?

OR, I read a post about the default CNID scheme needing a rebuild. See 


“Unlike other protocols like smb or nfs, the AFP protocol mostly refers to files and directories by ID and not by a path (the IDs are also called CNID, that means Catalog Node ID). A typical AFP request uses a directory ID and a filename, something like “server, please open the file named ‘Test’ in the directory with id 167”. For example “Aliases” on the Mac basically work by ID (with a fallback to the absolute path in more recent AFP clients. But this applies only to Finder, not to applications).”

and "Netatalk needs to map IDs to files and folders in the host filesystem. To achieve this, several different CNID backends are available and can be choosed by the cnidscheme option in theAppleVolumes.default(5) configuration file. A CNID backend is basically a database storing ID <-> name mappings.

The CNID Databases are by default located in the .AppleDB folder in every afpd volume root. With the new ADv2 format, afpd stores the files/directories ID in the corresponding .AppleDouble file as well.

Starting with Netatalk 2.1 there is a command line utility called  dbd  available which can be used to verify, repair and rebuild the CNID database."

this last point is key - dbd can rebuild the database. hmm - dbd not present.

So why would it just sit there? I tried connecting to the share from finder:


and this just hangs…

the log entries created on the sharespace are (names/numbers changed):

Jan  4 21:42:54 sharespacename daemon.info afpd[2432]: ASIP session:548(4) from 192.x.x.x:50922(7)

Jan  4 21:42:54 sharespacename daemon.info afpd[2432]: dhx login: WD_Backup

Jan  4 21:42:54 sharespacename daemon.info afpd[2432]: login WD_Backup (uid 502, gid 1000) AFP3.2

Jan  4 21:42:54 sharespacename daemon.warn afpd[2432]: Warning: No CNID scheme for volume /DataVolume/.timemachine. Using default.

Jan  4 21:42:54 ClaphamRAID daemon.info afpd[2432]: Setting uid/gid to 502/0

Jan  4 21:42:54 ClaphamRAID daemon.info afpd[2432]: CNID DB initialized using Sleepycat Software: Berkeley DB 4.2.52: (December  3, 2003)

Stumped… any ideas?

Still incredibly stumped. I’ve been all over the system - looking at how it’s put together, and from my scanning through the commands that are littered through it, I can’t see anything extra that may be screwing the config such that I can’t get in. 

Giving up.

Help please!

I had also issues which were similar as you described.

This solved the issues I had:

Check permissions, it should be 755 (/DataVolumes/.timemachine)

Change mDNSResponder.conf

If have commented the original config of WD:

And changed it to this:

“” _adisk._tcp local. 9 “sys=waMA=,adVF=0x100” “dk0=adVN=WD_Backup,adVF=0xa1”

Also I created the AFP share for time machine in /etc/netatalk/AppleVolumes.default:

/DataVolume/.timemachine “WD_Backup” allow:WD_Backup option:tm,upriv,usedots

This worked for me!


I do have the same problem and I appreciate your solution but could you please provide a “step by step” instruction. I can’t follow your brief solution.

Thank’s a lot.