Thumbnail images and network shares (SOLUTION)


#1

There has been a lot of talk about the thumbnail issue on network shares.  To re-cap; when a .jpg file with the same file name as the video exists (excluding the file extension) in the same directory then 2 (two) thumbnail images appear.  Yes this is (WAS) frustrating to me, until I tried something new, last night.  I don’t take credit for the idea, I got it from reading one of the other posts here on this forum. 

Here’s the solution (that worked for my setup)

Given that the thumbnail image file matches the video file…

Some Movie.AVI

Some Movie.jpg

the above would generate 2 (two) thumbnail images, one for the actual .jpg file and one for the move.

Simple putting a PERIOD (.) at the very beginning of the .jpg file name causes the thumbnail for the .jpg to disappear while leaving the correct thumbnail for the video file.  The PERIOD (.) at the beginning of the file name, in Linux, marks that file as a “hidden” file.

For example

Some Movie.AVI

.Some Movie.jpg

… results in the correct appearance on the screen.

Hopefully this will work for others…

John


#2

Welcome to the forum and great tip!  :)

Worked fine for “loose” films in my main folder but didn’t work as expected for films contained in subfolders (folder artwork still shows but when you go into the folder, the file no longer has a thumbnail).  

Should mention that I usually give each film its own folder then place a folder.jpg and filename.jpg inside it, along with the actual video and any SRT files.

Because of that, I’d be hesitant to call it a “solution” in case WD decide to halt any plans to actually FIX the network thumbs issue but it does seem to work as you describe for basic files and associated jpgs in one folder.

For anyone shaking their head at the thought of renaming dozens (if not hundreds) of images, check out Bulk Rename Utility:   http://www.bulkrenameutility.co.uk/

Select the folder containing ALL your movies / thumbnails.  In Selections (bottom of app) uncheck Folders and check Subfolders.  That should get you a view of all your files but not the folders.  Sort them by type and highlight all your JPG files.  In the ADD section, simply place a period (.) in the Prefix box.  Highlight all the files you want to change and it’ll show you a preview of how they’ll look.  If you’re happy, hit the Rename button (bottom right).

It’s an awesome little app and completely free, makes the process painless.


#3

No, this doesn’t work for me at all.

I have my MKV files in sub folders and while putting the period in front of the file name does make the JPG invisible, it also does not show up as a thumb (and I think for good reason – the Live tries to match up file names *exactly*, even including case, and with a period in front the names don’t match).

So – it looks as if it’s something that only works under very specialized conditions (maybe just on the root?) and thus not helpful to the majority of us.  But thanks for trying (and makes me ever more anxious for the thumbnail fix coming in firmware someday).


#4

Had a sneaking suspicion why this wasn’t working for subfolders so tried power cycling the Live (clears the image cache).

Sure enough, files and folders are no longer showing thumbs.  Bummer.

I guess this will only work for those who will never, ever turn off their power.

And of course, if you have your Live on a Smart Strip, you’ll never see any thumbs.

Definitely not a solution.  :(


#5

Isn’t this just a variation of the deleting or renaming of the jpg’s after they have been cached. As you say that only works if you never power off the WDTV. My computer for some reason does not let me add a period to the front of my files so I can’t try it.


#6

jsanders wrote:

There has been a lot of talk about the thumbnail issue on network shares.  To re-cap; when a .jpg file with the same file name as the video exists (excluding the file extension) in the same directory then 2 (two) thumbnail images appear.  Yes this is (WAS) frustrating to me, until I tried something new, last night.  I don’t take credit for the idea, I got it from reading one of the other posts here on this forum. 

 

Here’s the solution (that worked for my setup)

 

Given that the thumbnail image file matches the video file…

 

Some Movie.AVI

Some Movie.jpg

 

the above would generate 2 (two) thumbnail images, one for the actual .jpg file and one for the move.

 

Simple putting a PERIOD (.) at the very beginning of the .jpg file name causes the thumbnail for the .jpg to disappear while leaving the correct thumbnail for the video file.  The PERIOD (.) at the beginning of the file name, in Linux, marks that file as a “hidden” file.

 

For example

 

Some Movie.AVI

.Some Movie.jpg

 

… results in the correct appearance on the screen.

 

Hopefully this will work for others…

 

John

If you disconnect the power from your WDTV for say 10 minutes does it still see the thumbnails when you power up.


#7

I have now tried it and I’m afraid it does not work. As Mike says the names must be the same and the period changes that relationship. After a power off (unplugged) the WDTV cache forgets the old jpg and displays no thumbnail.


#8

WD:  this problem has exsisted for way too long, can’t you get around to fixing it already?  I love the “capabilities” of my WD LIVE, it’s easily one of my favorite “tech toys”, but the thing pisses me off sometimes. 


#9

http://community.wdc.com/t5/General-Discussions/What-I-don-t-like-about-WD/td-p/23752