Thumbnail Cache causes lockup in network shares

Can someone with WD please respond to this known issue.  I have had this problem if I use any firmware version above 1.01.24 and it is very easy to reproduce.   I own 3 WDTV Live players and all 3 devices behave in the same manner.  My friend has 2 and he can produce the same problem.  It has been posted in here several times from others with no response and all of the existing threads do not allow a person to reply anymore.  After about 100 or so thumbnails being displayed the player will slow down then completely lock up.  I must unplug the device to get it to unlock.  The player will work fine again until about 100 or so thumbnails have been displayed…then it will lock up again.  I can go to any network share I have and all will work fine until I reach that limit of thumbnails.  All of my thumbnails are very small 25kb or so. After firmware 1.01.24 the thumbnail images became much more vibrant but this issue persists.  I have tried every new firmware version released and every time the same problem persists and I must revert back to 1.01.24.  PLEASE HELP

Yes, the problem persist. My WD box also often hangs when browsing video section in thumbnail mode. I have a NAS 8TB WD SHARESPACE, so i have more than 500 HD videos with thumbnails. Also it is too hard to list all of >500 videofiles from A to Z one by one without shortcuts for example, by letter.  

Try to use:

Video -> 160X240 image size (Thumbnail) and allways with jpg type.

Music and Pictures -> The same but with 240X240 size

I have more then 100 thumbnails displayed and works great. 

All my thumbnails are the correct size and very small files.  I have probably 600 or so movies on several shared drives on my server.  The number may be over 100 exactly but the lock up will happen every time if I scan a couple of the drives looking for a movie.  Once too many thumbnails have been shown on the screen its locking up for sure…unless I run 1.01.24…then I can scan through every thumbnail in every drive without issue.  Anyone from WD want to comment?